Page MenuHomePhabricator

Allow IP for creating account for school project for 30 days - Informatika SZŠ Chomutov
Closed, ResolvedPublic

Description

As last year, pls allow 93.91.145.154 for creating accounts for school project for 30 days. www.esoz.cz, Czech Republic. We are on https://cs.wikiversity.org/wiki/Informatika_SZ%C5%A0_Chomutov. Approx. 100 student, UTC+2 (Prague). Sorry for being late, its starts tommorow.... 10.00am. Thank you very much.

Event Timeline

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptSep 9 2018, 2:51 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Urbanecm triaged this task as High priority.Sep 9 2018, 5:32 PM
Restricted Application added a subscriber: Dereckson. · View Herald TranscriptSep 9 2018, 5:33 PM

Change 459383 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] New throttle rule for Czech school

https://gerrit.wikimedia.org/r/459383

Urbanecm moved this task from Backlog to To deploy on the User-Urbanecm board.Sep 9 2018, 5:40 PM

Recapitulation:

  • From: 2018-09-10T09:00 +2:00
  • To: 2018-10-10T09:00 +2:00
  • IP: 93.91.145.154
  • Wikis: 'cswiki', 'commonswiki', 'wikidatawiki'
  • Value: 120/day

I also warn you that future throttle exemption requests created with less than one week notice may be declined. Fulfilling your request requires an extraordinary deploy.

Dereckson raised the priority of this task from High to Unbreak Now!.Sep 10 2018, 6:43 AM

Got a text message from @Urbanecm this rule is needed this morning.

Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptSep 10 2018, 6:43 AM
Dereckson lowered the priority of this task from Unbreak Now! to High.Sep 10 2018, 6:56 AM

Change 459383 merged by jenkins-bot:
[operations/mediawiki-config@master] New throttle rule for Czech school

https://gerrit.wikimedia.org/r/459383

Mentioned in SAL (#wikimedia-operations) [2018-09-10T07:04:14Z] <oblivian@deploy1001> Synchronized wmf-config/throttle.php: Deploy throttle rule for Czech School T203909 (duration: 00m 51s)

Dereckson closed this task as Resolved.Sep 10 2018, 7:05 AM

I also warn you that future throttle exemption requests created with less than one week notice may be declined. Fulfilling your request requires an extraordinary deploy.

OK, Got it.

Lugubelenus added a comment.EditedSep 11 2018, 11:19 AM

Should it be on now already? Its not.....

Thank you.

Yes, it should be up since Mon, Sep 10, 07:04 UTC.

I'm checking the rule against your IP.

@Lugubelenus On what wiki are you trying to create the account?

Okay I see the issue, the patch was for cs.wikipedia and not for cs.wikiversity, I'm fixing that.

Dereckson renamed this task from Allow IP for creating account for school project for 30 days to Allow IP for creating account for school project for 30 days - Informatika SZŠ Chomutov.Sep 11 2018, 11:26 AM
Dereckson reopened this task as Open.

Change 459775 had a related patch set uploaded (by Dereckson; owner: Dereckson):
[operations/mediawiki-config@master] Update Informatika SZŠ Chomutov throttle rule

https://gerrit.wikimedia.org/r/459775

Change 459775 merged by jenkins-bot:
[operations/mediawiki-config@master] Update Informatika SZŠ Chomutov throttle rule

https://gerrit.wikimedia.org/r/459775

Mentioned in SAL (#wikimedia-operations) [2018-09-11T12:01:51Z] <dereckson@deploy1001> Synchronized wmf-config/throttle.php: Update Informatika SZŠ Chomutov throttle rule (T203909) (duration: 00m 50s)

Dereckson closed this task as Resolved.Sep 11 2018, 12:02 PM

@Lugubelenus Should work on cs.wikiversity.org now.

Thank you, Ill check tomorrow.

Ok. it works. I forgot to ask for increasing rate limit for the same IP adress. Not sure if the term "rate limit" is ok - so all the newbies /all new created account/ can make nearly unlimited changes. Now we can not publish changes all at once, we have to wait for few minutes. Shall I make new thread? Thank you.

Ok. it works. I forgot to ask for increasing rate limit for the same IP adress.

It's not clear to me what this means. What "rate limit" do you refer to? How to run into a "rate limit"?

Now we can not publish changes all at once, we have to wait for few minutes.

Why not? If you run into some error, what is the error message? Please be exact so we can help.

Lugubelenus added a comment.EditedSep 17 2018, 1:18 PM

Well, I do not have the error message now, (and its in czech anyway), maybe czech admin @Urbanecm could help. Last year, when I had the same issue, he told me this (in czech): https://cs.wikiversity.org/wiki/Wikiverzita:Diskusn%C3%AD_prostor_(technika)#Akce_byla_pozastavena. Thank you.

@Lugubelenus: Je mi to jedno. :) Alright, thanks for the explanation. So this is about autoconfirmed right and probably wgRateLimitsExcludedIPs in https://noc.wikimedia.org/conf/InitialiseSettings.php.txt , I see.

@Lugubelenus Well, I really thought adding temporary lift for creating accounts does something with wgRateLimits as well. I was right, but it doesn't modify the rate limit for editing, as you can see on https://phabricator.wikimedia.org/source/mediawiki-config/browse/master/wmf-config/throttle-analyze.php... I think it _should_ modify it as well. As this task was about creating individual exception for account creating (which works), I'm creating another task for dicussions on this.