Page MenuHomePhabricator

"PHP Notice: Undefined index: revid" in SpecialThanks.php
Closed, ResolvedPublic

Description

Error

Request ID: W5leswrAIFIAAD3q9T8AAAAL

message
PHP Notice: Undefined index: revid
stacktrace
#0 /srv/mediawiki/php-1.32.0-wmf.20/extensions/Thanks/includes/SpecialThanks.php(149): MWExceptionHandler::handleError(integer, string, string, integer, array, array)
#1 /srv/mediawiki/php-1.32.0-wmf.20/includes/htmlform/HTMLForm.php(665): SpecialThanks->onSubmit(array, OOUIHTMLForm)
#2 /srv/mediawiki/php-1.32.0-wmf.20/includes/htmlform/HTMLForm.php(557): HTMLForm->trySubmit()
#3 /srv/mediawiki/php-1.32.0-wmf.20/includes/htmlform/HTMLForm.php(572): HTMLForm->tryAuthorizedSubmit()
#4 /srv/mediawiki/php-1.32.0-wmf.20/includes/specialpage/FormSpecialPage.php(184): HTMLForm->show()
#5 /srv/mediawiki/php-1.32.0-wmf.20/includes/specialpage/SpecialPage.php(569): FormSpecialPage->execute(string)
#6 /srv/mediawiki/php-1.32.0-wmf.20/includes/specialpage/SpecialPageFactory.php(581): SpecialPage->run(string)
#7 /srv/mediawiki/php-1.32.0-wmf.20/includes/MediaWiki.php(288): MediaWiki\Special\SpecialPageFactory->executePath(Title, RequestContext)
#8 /srv/mediawiki/php-1.32.0-wmf.20/includes/MediaWiki.php(868): MediaWiki->performRequest()
#9 /srv/mediawiki/php-1.32.0-wmf.20/includes/MediaWiki.php(525): MediaWiki->main()
#10 /srv/mediawiki/php-1.32.0-wmf.20/index.php(42): MediaWiki->run()
#11 /srv/mediawiki/w/index.php(3): include(string)

Notes

The few samples I checked were from form submissions (POST) when the user is on a url that looks like /wiki/Special:Thanks/Flow/#ID#.

Event Timeline

Krinkle created this task.Sep 13 2018, 12:50 AM
Restricted Application added a project: Growth-Team. · View Herald TranscriptSep 13 2018, 12:50 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Confirmed still present on 1.32.0-wmf.22.

Still present on 1.32.0-wmf.23.

Great, thanks for your work on this @Mh-3110!

Krinkle closed this task as Resolved.Oct 29 2018, 9:03 PM
Krinkle assigned this task to Mh-3110.
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:08 PM