Page MenuHomePhabricator

cloudvps: huggle project trusty deprecation
Closed, ResolvedPublic

Description

Ubuntu Trusty is no longer available in Cloud VPS since Nov 2017 for new instances. However, the EOL of Trusty is approaching in 2019 and we need to move to Debian Stretch before that date.

All instances in the huggle project needs to upgrade as soon as possible.

The list of affected VMs is:

  • huggle-pg.huggle.eqiad.wmflabs

Listed administrator are:

More info in openstack browser: https://tools.wmflabs.org/openstack-browser/project/huggle

Related Objects

Event Timeline

aborrero triaged this task as Medium priority.Sep 17 2018, 12:40 PM
aborrero created this task.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 17 2018, 12:40 PM
Krenair added a subscriber: Krenair.

Hey @Addshore @Petrb! Just a friendly reminder that you should get rid of your Trusty instances as described in https://wikitech.wikimedia.org/wiki/News/Trusty_deprecation#Cloud_VPS_projects. The deadline is 2018-12-18. Please get in contact if you need help. Also please assign this task to an individual.

Petrb added a comment.Oct 22 2018, 2:51 PM

Is there any LTS alternative that is going to suffice for next 5 - 10 years so that we don't need to go through this pointless hassle again in few years?

The options are Debian Jessie and Debian Stretch. Of the two, Debian Stretch has the most amount of time left.

aborrero added a comment.EditedNov 20 2018, 12:44 PM

Another ping. Deadline is approaching next month (2018-12-18).

Ping. Today is Friday and the deadline is Tuesday.

frankly I don't even know if this instance is in use anymore so I shut it down now and let's see if there are any errors triggered by either whitelist, huggle updater or wm-bot.

If not we can delete it next week

deleted from equiad and -r1

Petrb closed this task as Resolved.Dec 16 2018, 12:47 PM
Petrb claimed this task.