Page MenuHomePhabricator

cloudvps: mwoffliner project trusty deprecation
Closed, ResolvedPublic

Description

Ubuntu Trusty is no longer available in Cloud VPS since Nov 2017 for new instances. However, the EOL of Trusty is approaching in 2019 and we need to move to Debian Stretch before that date.

All instances in the mwoffliner project needs to upgrade as soon as possible.

The list of affected VMs is:

  • mwoffliner1.mwoffliner.eqiad.wmflabs
  • mwoffliner2.mwoffliner.eqiad.wmflabs
  • mwoffliner3.mwoffliner.eqiad.wmflabs
  • mwoffliner4.mwoffliner.eqiad.wmflabs
  • mwoffliner5.mwoffliner.eqiad.wmflabs

Listed administrator are:

More info in openstack browser: https://tools.wmflabs.org/openstack-browser/project/mwoffliner

Event Timeline

Krenair triaged this task as Medium priority.Sep 17 2018, 12:48 PM
Krenair created this task.

What does it means for me?
Should I do something myself?
Can we plan it around the end of the year?

Yes, you should phase out the use of trusty in your project by April 2019.

@Krenair How is the procedure to wipeout the old ubuntu and get a 18.04? Can I do that on my own?

Ubuntu is not supported, you need Debian Jessie or Stretch. The procedure
is to start new instances to replace the old ones.

Hey @Kelson! Just a friendly reminder that you should get rid of your Trusty instances as described in https://wikitech.wikimedia.org/wiki/News/Trusty_deprecation#Cloud_VPS_projects. The deadline is 2018-12-18. Please get in contact if you need help.

@Krenair Thank you for the reminder as I was believing the deadline is somewhere in Spring 2019. Will do the necessary in November.

Yes sorry about that, the upstream EOL was April but we seem to be getting
rid of Trusty instances in December.

Another ping. Deadline is approaching next month (2018-12-18).

I have migrated one of the 5, the 4 others will follow.

Kelson closed this task as Resolved.Dec 10 2018, 5:26 AM

All 5 boxes have been migrated to Debian Stretch