Page MenuHomePhabricator

cloudvps: pagemigration project trusty deprecation
Closed, DeclinedPublic

Description

Ubuntu Trusty is no longer available in Cloud VPS since Nov 2017 for new instances. However, the EOL of Trusty is approaching in 2019 and we need to move to Debian Stretch before that date.

All instances in the pagemigration project needs to upgrade as soon as possible.

The list of affected VMs is:

  • pagemigration-vagrant.pagemigration.eqiad.wmflabs

Listed administrator are:

More info in openstack browser: https://tools.wmflabs.org/openstack-browser/project/pagemigration

Event Timeline

Krenair triaged this task as Medium priority.Sep 17 2018, 4:13 PM
Krenair created this task.

Hey @coren @Meskobalazs @Nemo_bis @Nikerabbit @Phoenix303! Just a friendly reminder that you should get rid of your Trusty instances as described in https://wikitech.wikimedia.org/wiki/News/Trusty_deprecation#Cloud_VPS_projects. The deadline is 2018-12-18. Please get in contact if you need help.

Also please assign this task to an individual.

Why are you doing this? This project was already supposed to be deleted in the process of https://wikitech.wikimedia.org/wiki/News/Cloud_VPS_2018_Purge due to lack of interest to keep it.

Why are you doing this? This project was already supposed to be deleted in the process of https://wikitech.wikimedia.org/wiki/News/Cloud_VPS_2018_Purge due to lack of interest to keep it.

The project currently still exists and the purge status wasn't taken into account when creating the trusty deprecation tasks. This instance showed up when cumin was looking for trusty instances.

Also stuff not marked as used there still isn't eligible for deletion as part of the purge until the 1st of November.

You are right, it's little over one week before it can be purged. I'm just saying I doubt there would be volunteers to upgrade it, given there aren't volunteers that want it saved.

Well, that's fine. This task can be closed in that case.