Page MenuHomePhabricator

externallinks table no longer accessible on the replicas
Closed, DuplicatePublic

Description

It seems I can no longer access the externallinks table on the replicas. This broke XTools.

MariaDB [enwiki_p]> SHOW TABLES;
+---------------------------+
| Tables_in_enwiki_p        |
+---------------------------+
...
| externallinks             |
...
+---------------------------+
96 rows in set (0.00 sec)

MariaDB [enwiki_p]> DESCRIBE externallinks;
ERROR 1356 (HY000): View 'enwiki_p.externallinks' references invalid table(s) or column(s) or function(s) or definer/invoker of view lack rights to use them

Was this intentional?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 17 2018, 4:38 PM

Yes, this is part of: T114117#4589703
@Bstorm is going to re-run the views

@Bstorm finished the run:

root@labsdb1009.eqiad.wmnet[enwiki_p]> describe externallinks;
+-------------+------------------+------+-----+---------+-------+
| Field       | Type             | Null | Key | Default | Extra |
+-------------+------------------+------+-----+---------+-------+
| el_id       | int(10) unsigned | NO   |     | 0       |       |
| el_from     | int(8) unsigned  | NO   |     | 0       |       |
| el_to       | blob             | NO   |     | NULL    |       |
| el_index    | blob             | NO   |     | NULL    |       |
| el_index_60 | varbinary(60)    | NO   |     | NULL    |       |
+-------------+------------------+------+-----+---------+-------+
5 rows in set (0.01 sec)