Page MenuHomePhabricator

cloudvps: signwriting project trusty deprecation
Closed, ResolvedPublic

Description

Ubuntu Trusty is no longer available in Cloud VPS since Nov 2017 for new instances. However, the EOL of Trusty is approaching in 2019 and we need to move to Debian Stretch before that date.

All instances in the signwriting project needs to upgrade as soon as possible.

The list of affected VMs is:

  • signwriting-server.signwriting.eqiad.wmflabs

Listed administrator are:

More info in openstack browser: https://tools.wmflabs.org/openstack-browser/project/signwriting

Event Timeline

aborrero triaged this task as Medium priority.Sep 18 2018, 11:26 AM
aborrero created this task.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 18 2018, 11:26 AM

Thanks for the heads up. I tried to create a new server to replace the old, but the online documentation is out of date. Luckily, I still have access to the two-factor authentication, but I failed in my initial attempt. Later this year, I will attempt again.

There really shouldn't be any issue moving to an updated OS. It should be simply pulling the source from GitHub and possibly adding the GD graphics library or something.

the online documentation is out of date.

Please provide a link to what you refer to (otherwise we have to guess). Comments on the talk page describing what's incorrect are also highly welcome.

Thanks for the comments. I spent an hour or so working through the issue before giving up. I did not document my problems.

Next time, I will have more patience and I will use the chat channels. If I am unable to resolve my issues, I will add to the talk page or post specifics on this ticket.

Krenair assigned this task to Slevinski.Oct 22 2018, 9:32 AM
Krenair updated the task description. (Show Details)
Krenair added a subscriber: Krenair.

Hey @Slevinski! Some more details about this have been written at https://wikitech.wikimedia.org/wiki/News/Trusty_deprecation#Cloud_VPS_projects, and the deadline has also been put there as 2018-12-18. Please get in contact if you need help.

Thanks for the information. These servers are used for 3 sign language wikipedias on incubator. I will replace both servers with whatever is recommended. I hope I can keep the same URLs.

I will work on this in early December before the deadline. I will use chat if I need help. I should be able to create the servers in an afternoon.

Hi @Slevinski, right now it looks like there is only one instance which needs upgrading, signwriting-server.signwriting.eqiad.wmflabs. The others both run Debian.
You will be able to keep the same domains and just point them at the new backend hostnames.

Another ping. Deadline is approaching (2018-12-18).

Slevinski closed this task as Resolved.Dec 6 2018, 7:19 PM

This is done. The instances have been recreated with Debian stretch.