Page MenuHomePhabricator

Article names on "Recent Changes" IRC feed have lost wikilinks when protecting/unprotecting
Closed, DeclinedPublic

Description

<@rc> [[Special:Log/protect]] protect * Nakon * protected User:Nakon/b [edit=autoconfirmed] (indefinite) [move=autoconfirmed] (indefinite): test

should read

<@rc> [[Special:Log/protect]] protect * Nakon * protected [[User:Nakon/b]] [edit=autoconfirmed] (indefinite) [move=autoconfirmed] (indefinite): test


Version: unspecified
Severity: normal

Details

Reference
bz18541

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 10:35 PM
bzimport set Reference to bz18541.
bzimport added a subscriber: Unknown Object (MLST).
Nakon created this task.Apr 21 2009, 3:41 AM

Hi Nakon! Sorry that nobody has taken a look at this report yet and given feedback.

For anybody who wants to give it a try: General info on IRC feeds is at
https://meta.wikimedia.org/wiki/IRC/Channels#Recent_changes

Watching http://en.wikipedia.org/w/index.php?title=Special%3ALog&type=protect&user=&page=&year=&month=-1&tagfilter= I can confirm the problem:

Jan 29 22:31:16 <rc-pmtpa> [[Special:Log/protect]] protect * Diannaa * protected Neil Young [Edit=Block new and unregistered users] (expires 21:31, 5 February 2013 (UTC)) [Move=Block new and unregistered users] (expires 21:31, 5 February 2013 (UTC)): Violations of the [[WP:BLP|biographies of living persons policy]]

Neil Young should have been [[Neil Young]].

Krenair set Security to None.
Rxy added a subscriber: Rxy.Mar 9 2016, 1:18 PM

Does @Krinkle's comment at T53329#559212 apply here? (i.e., it's kept as it is for backward compatibility, new clients should use a more modern alternative for better machine-readability)

Krinkle closed this task as Declined.Mar 18 2016, 12:45 AM

Yeah, this has been that way at least since 2009 as you can see. So unless this was a recent regression, the feature freeze applies here.

There should be no problem with the format as it is. It is perhaps inconsistent with other events but can still be dealt with from the client perspective, and changing it would effectively break all existing clients.