Page MenuHomePhabricator

[testwiki-wmf.23] Cannot disable new version for translations
Closed, ResolvedPublic

Description

  1. On testwiki make one translation with version=2.
  2. After that disable the version 2 and start another translation. The new translation will be started with &version=2.

Related ticket: T203864: Resetting a global preference via API does not work

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 25 2018, 9:38 PM

I haven't used "Try new version" switcher on test wiki before. So, I tried starting a new translation. Started correctly with &version=1.

Then I went on to actually click "Try new version" on test wiki. Starting new translation used &version=2. Going back to dashboard and clicking "Disable" in the switcher made new translation use version=1.

In other words, all went well.
Did you do something differently? Or was this on cx2-testing?

@Petar.petkovic I was testing in testwiki. I think that I missed one step in the description - to actually translate some text, not simply opening articles with different versions. After that the version 2 selection gets stuck.

I have tried to click "Try new version", start translation (CX2), add some paragraphs, save, go back to dashboard, click "Disable" and start new translation. First translation starts in CX2, the second in CX1.

Trying the same steps, with publishing after save, leads to the same outcome. All looks good again. Wondering what am I doing wrong here.

Interesting - I tried to test it with test user who did not have ContentTranslation beta feature enabled - it was possible to Disable cx2 but only once. After that I tried o switch to a different browser, clear all browser history, reset all user settings to default - I cannot disable cx2.

@Petar.petkovic - if you click on 'Disable' and then re-load the page, will you still see the link 'View new version" disabled? Did you translate via 'New translation' box?

Looks like this is also case of current production (ie wmf.22).

  1. Enable CX2
  2. Start new translation. Save.
  3. Go back to dashboard and disable CX2.
  4. Start new translation. URL has version=2 and after that it will only open translations in CX2.

Translations in draft started with CX1 loads fine as CX1.

If CX2 is enable and then disabled, reloading dashboard switch backs to CX2.

If CX2 is enable and then disabled, reloading dashboard switch backs to CX2.

After having a meeting with @KartikMistry, we concluded that the problem is that disabling does not go through. That becomes clear when the page is reloaded. He was not able to disable the CX2 once enabled, on guwiki. I still cannot reproduce in production on testwiki and srwiki.

So, the problem is that disabling is not working for some reason, not that version is incorrectly applied.

Pginer-WMF triaged this task as High priority.Sep 26 2018, 7:52 AM
Pginer-WMF moved this task from Needs Triage to CX2 on the ContentTranslation board.
Pginer-WMF moved this task from Backlog to Priority backlog on the Language-2018-July-September board.

Change 462878 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Use numerical option when setting CX version preference

https://gerrit.wikimedia.org/r/462878

Change 462878 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Use numerical option when setting CX version preference

https://gerrit.wikimedia.org/r/462878

Change 463232 had a related patch set uploaded (by KartikMistry; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@wmf/1.32.0-wmf.23] Use numerical option when setting CX version preference

https://gerrit.wikimedia.org/r/463232

Change 463232 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@wmf/1.32.0-wmf.23] Use numerical option when setting CX version preference

https://gerrit.wikimedia.org/r/463232

Mentioned in SAL (#wikimedia-operations) [2018-09-27T11:44:33Z] <zfilipin@deploy1001> Synchronized php-1.32.0-wmf.23/extensions/ContentTranslation/: SWAT: [[gerrit:463232|Use numerical option when setting CX version preference (T205493)]] (duration: 00m 57s)

Etonkovidova closed this task as Resolved.Sep 28 2018, 12:00 AM

Checked the fix in enwiki (wmf.23) - switching between translation version is fine. Also &version=1 or &version=2 will be correctly displayed in the url.

Pginer-WMF updated the task description. (Show Details)Sep 28 2018, 10:21 AM