Page MenuHomePhabricator

PHP Fatal Error "Class undefined: HTML" from ThreeDThumbnailImage.php
Closed, ResolvedPublicPRODUCTION ERROR

Description

Error

Request ID: W6ustArAEEUAAFbIwH8AAAAF

message
[{exception_id}] {exception_url} PHP Fatal Error from line 36 of /srv/mediawiki/php-1.32.0-wmf.23/extensions/3D/src/ThreeDThumbnailImage.php: Class undefined: HTML MediaWiki or an installed extension requires this class but it is not embedded directly
stacktrace
#0 /srv/mediawiki/php-1.32.0-wmf.23/extensions/3D/src/ThreeDThumbnailImage.php(36): NO_FUNCTION_GIVEN()
#1 /srv/mediawiki/php-1.32.0-wmf.23/includes/gallery/TraditionalImageGallery.php(161): MediaWiki\Extensions\ThreeD\ThreeDThumbnailImage->toHtml(array)
#2 /srv/mediawiki/php-1.32.0-wmf.23/includes/parser/Parser.php(5186): TraditionalImageGallery->toHTML()
#3 /srv/mediawiki/php-1.32.0-wmf.23/includes/parser/CoreTagHooks.php(157): Parser->renderImageGallery(string, array)
#4 /srv/mediawiki/php-1.32.0-wmf.23/includes/parser/Parser.php(3970): CoreTagHooks::gallery(string, array, Parser, PPFrame_Hash)
#5 /srv/mediawiki/php-1.32.0-wmf.23/includes/parser/Preprocessor_Hash.php(1188): Parser->extensionSubstitution(array, PPFrame_Hash)
#6 /srv/mediawiki/php-1.32.0-wmf.23/includes/parser/Parser.php(3016): PPFrame_Hash->expand(PPNode_Hash_Tree, integer)
#7 /srv/mediawiki/php-1.32.0-wmf.23/includes/parser/Parser.php(1352): Parser->replaceVariables(string)
#8 /srv/mediawiki/php-1.32.0-wmf.23/includes/parser/Parser.php(476): Parser->internalParse(string)
#9 /srv/mediawiki/php-1.32.0-wmf.23/includes/content/WikitextContent.php(341): Parser->parse(string, Title, ParserOptions, boolean, boolean, integer){{{{
#10 /srv/mediawiki/php-1.32.0-wmf.23/includes/content/AbstractContent.php(517): WikitextContent->fillParserOutput(Title, integer, ParserOptions, boolean, ParserOutput)
#11 /srv/mediawiki/php-1.32.0-wmf.23/includes/Revision/RenderedRevision.php(217): AbstractContent->getParserOutput(Title, integer, ParserOptions, boolean)
#12 /srv/mediawiki/php-1.32.0-wmf.23/includes/Revision/RevisionRenderer.php(169): MediaWiki\Revision\RenderedRevision->getSlotParserOutput(string)
#13 /srv/mediawiki/php-1.32.0-wmf.23/includes/Revision/RevisionRenderer.php(122): MediaWiki\Revision\RevisionRenderer->combineSlotOutput(MediaWiki\Revision\RenderedRevision, array)
#14 [internal function]: Closure$MediaWiki\Revision\RevisionRenderer::getRenderedRevision#2(MediaWiki\Revision\RenderedRevision, array)
#15 /srv/mediawiki/php-1.32.0-wmf.23/includes/Revision/RenderedRevision.php(176): call_user_func(Closure$MediaWiki\Revision\RevisionRenderer::getRenderedRevision#2;3004, MediaWiki\Revision\RenderedRevision, array)
#16 /srv/mediawiki/php-1.32.0-wmf.23/includes/poolcounter/PoolWorkArticleView.php(188): MediaWiki\Revision\RenderedRevision->getRevisionParserOutput()
#17 /srv/mediawiki/php-1.32.0-wmf.23/includes/poolcounter/PoolCounterWork.php(123): PoolWorkArticleView->doWork()
#18 /srv/mediawiki/php-1.32.0-wmf.23/includes/page/Article.php(771): PoolCounterWork->execute()
#19 /srv/mediawiki/php-1.32.0-wmf.23/includes/actions/ViewAction.php(68): Article->view()
#20 /srv/mediawiki/php-1.32.0-wmf.23/includes/MediaWiki.php(501): ViewAction->show()
#21 /srv/mediawiki/php-1.32.0-wmf.23/includes/MediaWiki.php(294): MediaWiki->performAction(Article, Title)
#22 /srv/mediawiki/php-1.32.0-wmf.23/includes/MediaWiki.php(868): MediaWiki->performRequest()
#23 /srv/mediawiki/php-1.32.0-wmf.23/includes/MediaWiki.php(525): MediaWiki->main()
#24 /srv/mediawiki/php-1.32.0-wmf.23/index.php(42): MediaWiki->run()

Notes

Regression introduced by 33b179cb0885cf28aef06b7c6a75b4d9c8596ab9.

Event Timeline

Krinkle created this task.Sep 26 2018, 4:16 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptSep 26 2018, 4:16 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
zeljkofilipin triaged this task as Unbreak Now! priority.Sep 26 2018, 4:23 PM
zeljkofilipin added a subscriber: zeljkofilipin.

Changing priority to 😱Unbreak Now!🤯 since it's blocking the train!

Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptSep 26 2018, 4:23 PM
zeljkofilipin added a subscriber: Esanders.

@Esanders looks like you've created the commit that caused the problem (33b179cb0885), could you please take a look?

Change 463114 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/3D@master] Follow-up 33b179cb0: It's Html, not HTML, and PHP's autoloader is case sensitive

https://gerrit.wikimedia.org/r/463114

Change 463115 had a related patch set uploaded (by Krinkle; owner: Jforrester):
[mediawiki/extensions/3D@wmf/1.32.0-wmf.23] Follow-up 33b179cb0: It's Html, not HTML, and PHP's autoloader is case sensitive

https://gerrit.wikimedia.org/r/463115

Change 463114 merged by jenkins-bot:
[mediawiki/extensions/3D@master] Follow-up 33b179cb0: It's Html, not HTML, and PHP's autoloader is case sensitive

https://gerrit.wikimedia.org/r/463114

Change 463115 merged by jenkins-bot:
[mediawiki/extensions/3D@wmf/1.32.0-wmf.23] Follow-up 33b179cb0: It's Html, not HTML, and PHP's autoloader is case sensitive

https://gerrit.wikimedia.org/r/463115

Mentioned in SAL (#wikimedia-operations) [2018-09-26T17:22:55Z] <jforrester@deploy1001> Synchronized php-1.32.0-wmf.23/extensions/3D/src/ThreeDThumbnailImage.php: Hot-deploy I5bb4b699a fix for T205554 train-blocker (duration: 00m 56s)

Jdforrester-WMF closed this task as Resolved.Sep 26 2018, 5:24 PM
Jdforrester-WMF claimed this task.
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:07 PM