Page MenuHomePhabricator

Conflict simulation preview not choosing sides correctly
Closed, ResolvedPublic5 Estimated Story Points

Description

I got confused while testing an playing with the empty line handling. - It seems the simulation page does not choose the selected sides correctly

Steps to reproduce:

  • Simulate a change and change something
  • Select your side with your changes
  • Submit simulation preview
  • Your version will not be in the preview

Event Timeline

WMDE-Fisch renamed this task from Conflict simulation preview not showing newlines correctly to Conflict simulation preview not choosing sides correctly.Oct 1 2018, 11:33 AM
WMDE-Fisch updated the task description. (Show Details)

Sorry for turning this task around completely. By another test I just realized what the real problem is. ;-)

Lea_WMDE set the point value for this task to 5.Oct 2 2018, 12:36 PM

Probably this is related to the self built "preview" of the simulation that might not yet actually react to the new frontend.

WMDE-Fisch moved this task from Sprint Backlog to Doing on the WMDE-QWERTY-Sprint-2018-09-25 board.

Adding this to the sprint since the backlog is empty and the only review left hangs on the translate issue.

Change 464571 had a related patch set uploaded (by WMDE-Fisch; owner: WMDE-Fisch):
[mediawiki/extensions/TwoColConflict@master] Fix SpecialPage preview for the new interface

https://gerrit.wikimedia.org/r/464571

Change 464571 merged by jenkins-bot:
[mediawiki/extensions/TwoColConflict@master] Fix SpecialPage preview for the new interface

https://gerrit.wikimedia.org/r/464571

Lea_WMDE closed this task as Resolved.Oct 8 2018, 1:54 PM
Lea_WMDE moved this task from Demo to Done on the WMDE-QWERTY-Sprint-2018-09-25 board.