Page MenuHomePhabricator

Current version of text extracts list compatibility with 1.29 but uses 1.30 code
Closed, ResolvedPublic


Extension.json list the requirements for "MediaWiki": ">= 1.29.0" but in ApiQueryExtracts.php on line 238 you are using MediaWikiServices::getInstance()->getParserCache() which did not become available until MW 1.30.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 1 2018, 7:14 PM
Jdlrobson triaged this task as Low priority.Oct 2 2018, 10:02 PM
Jdlrobson added a subscriber: Jdlrobson.

Please feel free to submit a patch to fix this! Will happily review.

Change 464138 had a related patch set uploaded (by TheDJ; owner: TheDJ):
[mediawiki/extensions/TextExtracts@master] Raise mediawiki requirement to 1.30

TheDJ added a subscriber: TheDJ.Oct 3 2018, 12:26 PM

We should really have some CI linting on issues like this. Happens way too often.

Change 464138 merged by Jdlrobson:
[mediawiki/extensions/TextExtracts@master] Raise mediawiki requirement to 1.30

Thanks @TheDJ what would such linting look like? Shall we open a task?

Jdlrobson closed this task as Resolved.Oct 3 2018, 4:10 PM
Jdlrobson claimed this task.