Page MenuHomePhabricator

Outdated thumbnail for djvu file on Commons cannot be purged and does not update
Open, Needs TriagePublic

Description

Yesterday, during upload of this file:
https://commons.wikimedia.org/wiki/File:PL_Jean_de_La_Fontaine_-_Bajki.djvu
I have got "system under maintanance" error message. After that (as a result of the error?) some thumbnails of pages from this file were not updated. Especially, one of them:
https://upload.wikimedia.org/wikipedia/commons/thumb/d/d8/PL_Jean_de_La_Fontaine_-_Bajki.djvu/page657-1024px-PL_Jean_de_La_Fontaine_-_Bajki.djvu.jpg
is critical for Polish Wikisource.

Please advice, how can we update it, or clear it manually in the cache.

Event Timeline

Ankry created this task.Oct 4 2018, 6:14 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 4 2018, 6:14 AM
Ankry added a comment.Oct 4 2018, 6:17 AM

Another outdated thumbnail is
https://upload.wikimedia.org/wikipedia/commons/thumb/d/d8/PL_Jean_de_La_Fontaine_-_Bajki.djvu/page657-3669px-PL_Jean_de_La_Fontaine_-_Bajki.djvu.jpg
(but this one is not critical for us).
The page=657 was the only page modified in the recent revision of the file.

Ankry added a comment.EditedOct 4 2018, 6:25 AM

Please also point out, if there is a standard procedure that can be applied in such cases before reporting here.

Aklapper renamed this task from Please, remove outdated thumbnail from cache or update it to Outdated thumbnail for djvu file on Commons cannot be purged and does not update.Oct 4 2018, 6:52 AM
Gilles added a subscriber: Gilles.Oct 4 2018, 9:24 AM

It's the purge that's malfunctioning and not purging the thumbnails for that file at all.

GET parameters get filtered out, that's why they're not allowing you to bypass the cache, but this trick works: https://upload.wikimedia.org/wikipedia/commons/thumb/d/d8/PL_Jean_de_La_Fontaine_-_Bajki.djvu/page657-1024px-PL_Jean_de_La_Fontaine_-_Bajkifoo.djvu.jpg

Other DJVus purge fine. Since you mention that there was an error an upload time, maybe try to reupload the latest version of the file? It's possible that you hit a read-only phase for some of the upload process which left some of the data in a semi-broken state.

Ankry added a comment.Oct 4 2018, 3:02 PM

Other DJVus purge fine. Since you mention that there was an error an upload time, maybe try to reupload the latest version of the file? It's possible that you hit a read-only phase for some of the upload process which left some of the data in a semi-broken state.

@Gilles Reuploaded and no effect. Successfull upload this time, no error message. Previously uploaded file deleted to avoid SHA1 conflicts that prevent reupload.

It seems to me that some relation between file and its cache entries has been broken.
What else can be done here?

Ankry added a comment.Oct 21 2018, 9:24 PM

The thumbnails seem to be OK already.
@Gilles can it be closed? Or there is something more to do here?

Gilles closed this task as Resolved.Oct 22 2018, 11:25 AM
Gilles claimed this task.

No, I think it's impossible to reproduce the exact conditions that happened during upload and caused this. It seems like the various expiry mechanisms ultimately rectified that thumbnail, thanks for the update.

Ankry reopened this task as Open.Dec 12 2018, 10:28 PM
Aklapper removed Gilles as the assignee of this task.Jan 26 2019, 12:19 PM
Matlin added a subscriber: Matlin.Jan 27 2019, 10:59 AM