Page MenuHomePhabricator

Request Sauce Labs access for niedzielski
Closed, ResolvedPublic

Description

Please add user "niedzielski" to the Wikimedia Sauce Labs organization. Access to Sauce Labs would be very useful for ensuring the website displays correctly on a variety of devices and reproducing bugs. Please excuse this request if you are not stewards of the Sauce Labs account permissions.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 5 2018, 7:15 PM
zeljkofilipin triaged this task as Medium priority.

For my future reference:

zeljkofilipin closed this task as Resolved.Oct 9 2018, 5:03 PM

@Niedzielski I've invited you. Please reopen the task if you have any problems creating the account, logging in, using the service...

Niedzielski reopened this task as Open.Apr 25 2019, 6:00 PM
Niedzielski added a subscriber: greg.

@zeljkofilipin, I'm reopening this task as Sauce Labs now says "Your trial period has ended." /cc @greg who is listed on wiki as a contact for the wikimedia account.

Looks like the last time I've sent the invitation to your private e-mail. I've sent it now to your wikimedia e-mail. Let me know if you have trouble using the account.

zeljkofilipin closed this task as Resolved.Apr 30 2019, 1:14 PM
Niedzielski reopened this task as Open.Apr 30 2019, 3:08 PM

Thanks for looking into this, @zeljkofilipin! I tried to use the invitation but I think we're out of licenses :[ The error I get is: user:wikimedia is over subaccount capacity limit (9 >= 5).

@AndyRussG @dduvall @Mattflaschen-WMF @Niedzielski @SBisson I have deleted your sauce labs accounts. As far as I could see at the team management page, you did not use them. If you need the account, let me know.

Haven't used it in years. Thanks for cleaning that up.

@Niedzielski try again. I've removed unused accounts. It should work now. Please resolve the ticked if it works. :)

Niedzielski closed this task as Resolved.Apr 30 2019, 3:49 PM

Thanks @zeljkofilipin (and thank you for such prompt resolution)! It works! \o/

Niedzielski reopened this task as Open.Aug 27 2019, 7:07 PM

@zeljkofilipin, I'm getting "Your trial period has ended. Upgrade now..." messages again :[ Can you take a look?

Apologies for the late reply, I was really busy with T220745: 1.34.0-wmf.20 deployment blockers 🚂

There's just 3 accounts at https://app.saucelabs.com/team-management:

All of them seem to be configured the same. I don't see why your account would get that message. 🤔

@Etonkovidova is sauce labs working fine for you?

@Niedzielski the only think that comes to my mind is to delete your account and recreate it. Do you have any history that you care about, or can I delete/recreate the account?

@Niedzielski which data center are you logging in to? US West 1, EU Central 1, Headless US-East? I don't know that it matters, just checking.

@zeljkofilipin, I'm getting "Your trial period has ended. Upgrade now..." messages again :[ Can you take a look?

Yes, I got the same message but only when I attempt to use real mobile devices option. All other options (browsers combos and mobile emulators) seem to be available.

@Niedzielski do you have the same problem as @Etonkovidova? Or do you get the error message all the time?

zeljkofilipin removed zeljkofilipin as the assignee of this task.EditedSep 5 2019, 12:58 PM
zeljkofilipin added a subscriber: zeljkofilipin.

@Niedzielski seems to be out of the office.

thcipriani added a subscriber: thcipriani.

@Niedzielski do you have the same problem as @Etonkovidova? Or do you get the error message all the time?

Assigning to @Niedzielski for when he's back.

I've been using Sauce Labs recently and I had no trouble. Let me know if the problem is still there.

Niedzielski closed this task as Resolved.Nov 14 2019, 2:26 PM

@zeljkofilipin, thank you! This seems to be working for me now.

zeljkofilipin awarded a token.