Page MenuHomePhabricator

Password reset needed following Wikimedia developer account creation problem
Closed, ResolvedPublic

Description

I followed all the steps in the https://toolsadmin.wikimedia.org/register/ (connected my Wikimedia account using OAuth, set password, etc.) but after getting to the login page, my password did not work and I did not receive a confirmation email. Now I’m receiving “Wikimedia account is already in use.” When I try the registration again!

Can anyone check to see what is wrong there?
Is there any way to remove the account or reset the password?

BTW: I tried https://wikitech.wikimedia.org/w/index.php?title=Special:CreateAccount and my chosen username (“Meisam”) seems to be already registered!

Event Timeline

Meisam created this task.Oct 6 2018, 2:57 PM
bd808 edited projects, added Cloud-Services; removed Striker.Oct 7 2018, 11:26 PM
bd808 added a subscriber: bd808.

@Meisam, based on what I can see in the LDAP directory which is used to store developer account information my guess is that you actually set your password to something different than you think you did. LDAP shows the account being created 2018-10-06T10:09:15Z followed by 17 failed password attempts between 2018-10-06T10:09:29.872913Z and 2018-10-06T14:42:24.100338Z.

Because of T174469: LDAP account that is not attached on wikitech has no means for password reset I have attached the developer account to wikitech to make a password reset possible:

$ ssh labweb1001.wikimedia.org
$ mwscript extensions/OpenStackManager/maintenance/attachLdapUser.php --wiki=labswiki --user=Meisam --email={redacted}

Now that this has been done you should be able to go to https://wikitech.wikimedia.org/wiki/Special:PasswordReset, enter your username (Meisam) and email address, and submit the form to receive a password reset link by email that will allow you to set the password to a new value.

bd808 renamed this task from Wikimedia developer account creation problem to Password reset needed following Wikimedia developer account creation problem.Oct 7 2018, 11:26 PM
Meisam added a comment.Oct 8 2018, 1:22 PM

@bd808, Thanks for your helps. The problem is solved.
BTW, I use a password manager to keep track of these. Don’t know what went wrong there!

Meisam closed this task as Resolved.Oct 8 2018, 1:23 PM
Meisam claimed this task.