Page MenuHomePhabricator

Mailgun extension error on 특수:이메일확인 page
Open, Needs TriagePublic

Description

Note: This task was forwarded from Topic:Ulmvgr9pmz2b1ven on MediaWiki.org.

Exception encountered, of type "Error"
[ff4cd43337366b8f516cf825] /w/index.php?title=%ED%8A%B9%EC%88%98:%EC%9D%B4%EB%A9%94%EC%9D%BC%ED%99%95%EC%9D%B8 Error from line 42 of (webdir)/w/extensions/Mailgun/MailgunHooks.php: Class 'Http\Adapter\Guzzle6\Client' not found
Backtrace:
#0 (webdir)/w/includes/Hooks.php(195): MailgunHooks::onAlternateUserMailer(array, array, MailAddress, string, string)
#1 (webdir)/w/includes/mail/UserMailer.php(344): Hooks::run(string, array)
#2 (webdir)/w/includes/mail/UserMailer.php(189): UserMailer::sendInternal(array, MailAddress, string, string, array)
#3 (webdir)/w/includes/user/User.php(4301): UserMailer::send(array, MailAddress, string, string, array)
#4 (webdir)/w/includes/user/User.php(4275): User->sendMail(string, string)
#5 (webdir)/w/includes/specials/SpecialConfirmemail.php(133): User->sendConfirmationMail()
#6 (webdir)/w/includes/htmlform/HTMLForm.php(613): EmailConfirmation->submitSend(array, OOUIHTMLForm)
#7 (webdir)/w/includes/htmlform/HTMLForm.php(510): HTMLForm->trySubmit()
#8 (webdir)/w/includes/htmlform/HTMLForm.php(525): HTMLForm->tryAuthorizedSubmit()
#9 (webdir)/w/includes/specials/SpecialConfirmemail.php(106): HTMLForm->show()
#10 (webdir)/w/includes/specials/SpecialConfirmemail.php(68): EmailConfirmation->showRequestForm()
#11 (webdir)/w/includes/specialpage/SpecialPage.php(479): EmailConfirmation->execute(NULL)
#12 (webdir)/w/includes/specialpage/SpecialPageFactory.php(577): SpecialPage->run(NULL)
#13 (webdir)/w/includes/MediaWiki.php(282): SpecialPageFactory::executePath(Title, RequestContext)
#14 (webdir)/w/includes/MediaWiki.php(735): MediaWiki->performRequest()
#15 (webdir)/w/includes/MediaWiki.php(509): MediaWiki->main()
#16 (webdir)/w/index.php(43): MediaWiki->run()
#17 {main}

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 7 2018, 9:32 AM
Mainframe98 closed this task as Invalid.Oct 7 2018, 9:36 AM
Mainframe98 added a subscriber: Mainframe98.

This looks like composer has not been run. Looking at composer.json in rEMLG: https://phabricator.wikimedia.org/diffusion/EMLG/browse/master/composer.json, shows that it depends on the guzzlehttp package, is provided through composer.

@Gochiusa said they already ran composer update.

For the extension (not MediaWiki itself)?

Yes. I ran composer update in Mailgun directory. I also tried composer install, even release archive.

PlavorSeol reopened this task as Open.Oct 7 2018, 9:47 AM

Reopened per @Gochiusa's comment.

I'll try to see if I can reproduce this error.

Alright, that helps narrow it down. The exception states that Class 'Http\Adapter\Guzzle6\Client' not found, but it is present in the php-http package downloaded by composer on my install.

Can you confirm that the file Client.php exists in vendor/php-http/guzzle6-adapter/src/?

ls vendor/php-http/guzzle6-adapter/src
Client.php  Promise.php

Thanks for assistant.

PlavorSeol removed a subscriber: revi.EditedOct 8 2018, 5:01 AM

Not needed.
WARNING: @Liuxinyu970226, DO NOT add him as a subscriber just because someone is Korean.

Gochiusa edited subscribers, added: revi; removed: Liuxinyu970226.Oct 8 2018, 5:50 AM

한국어로 도움을 받을 수 있다면 더 좋을 것 같습니다 :)

This comment was removed by PlavorSeol.
PlavorSeol edited subscribers, added: Liuxinyu970226; removed: revi.EditedOct 8 2018, 11:02 AM

Rolled back all weird actions by @Liuxinyu970226
@Liuxinyu970226, I WARNED YOU NOT TO ADD HIM AS A SUBSCRIBER JUST BECAUSE SOMEONE IS KOREAN. IF YOU CONTINUE, I WILL REQUEST TO BLOCK YOUR ACCOUNT.

@PlavorSeol, please keep the Phabricator Etiquette in mind. Please keep this conversation civil.

revi added a comment.Oct 8 2018, 11:05 AM

Please know that shouting is not good manner. Read the Phabricator etiquette (and the following Code of Conduct).

So interesting.

Tenpower removed a subscriber: Tenpower.Oct 8 2018, 11:33 AM
Liuxinyu970226 added a comment.EditedOct 8 2018, 12:00 PM

The reason why I pinged revi is that I need his help to confirm that if only that page has this issue, or if this can be happened on random Korean pages. If he will not, he can just unsubscribe himself. Vandaling on subscriber(s) field is unhelpful for any questions that anyone meets.

@Liuxinyu970226 I'm warning you again, DO NOT add him as a subscriber ANYWAY. Never try to justify your crime.

@PlavorSeol Ah okay I won't do it again.

In reply to T206415#4649229:
@PlavorSeol: Please change your tone if you would like to continue using Wikimedia Phabricator. Calling subscribing someone a "crime" is not acceptable.
This is a last warning. Thanks for your understanding and for keeping this a respectful place.

@Aklapper I'm very sorry for that. I will try to change my tone.