Page MenuHomePhabricator

Holistically review OOUI components used in Visual Editor dialogs
Open, Needs TriagePublic

Description

Background: Some of the OOUI components behave unexpectedly on different screen sizes.

Proposed Solution: We need to audit the screens of the existing userflow (for persona Yanko) and identify visual inconsistencies and pain points.

Useful Documents:

Event Timeline

Restricted Application added a subscriber: Aklapper. ยท View Herald TranscriptOct 8 2018, 3:11 PM
iamjessklein added a comment.EditedOct 8 2018, 4:41 PM

To get this work started, I'm going to make a visual map of the screens of the experience.

This will help us to:

  • look for patterns
  • look for inconsistencies

cc/ @Volker_E

iamjessklein closed this task as Resolved.Oct 17 2018, 4:50 PM
iamjessklein moved this task from To Triage to Up next on the VisualEditor board.
Restricted Application added a project: User-Ryasmeen. ยท View Herald TranscriptOct 17 2018, 4:50 PM
JTannerWMF moved this task from Up next to Current work on the VisualEditor board.Oct 17 2018, 4:57 PM
JTannerWMF edited projects, added VisualEditor (Current work); removed VisualEditor.
Volker_E updated the task description. (Show Details)Oct 17 2018, 5:10 PM
iamjessklein reopened this task as Open.Oct 17 2018, 5:36 PM
iamjessklein added a comment.EditedNov 8 2018, 12:17 AM

I made a flow diagram T208737 for the purpose of figuring out what components are part of the section editing experience - I think that it's also worth taking a look at for OOUI.

cc/ @Volker_E

Volker_E added a comment.EditedNov 8 2018, 12:27 AM

The flow diagram is a nice start @iamjessklein! I've left some comments on InVision about possible improvement tasks and open questions.
Out of interest to reproduce layouts, which screen size did you use (especially width) for it?

It's the iphone xs with firefox - so just under 3inches.

It's the iphone xs with firefox - so just under 3inches.

What are inches? *scnr*
375x812 was what I was searching for.

JTannerWMF set Due Date to May 7 2019, 4:00 AM.Apr 19 2019, 8:14 PM
Restricted Application changed the subtype of this task from "Task" to "Deadline". ยท View Herald TranscriptApr 19 2019, 8:14 PM
Restricted Application changed the subtype of this task from "Deadline" to "Task". ยท View Herald TranscriptJun 11 2019, 2:09 PM

I guess there's no more activity left happening here, right? @iamjessklein

Right. Since the Editing Team has switched priorities to Talk pages, this
has been put in the freezer for a bit.