Page MenuHomePhabricator

AWB error connecting to miraheze: "Received an unexpected EOF or 0 bytes from the transport stream."
Closed, ResolvedPublic

Description

My AWB is having an error connecting to my wiki at platproject.miraheze.org. The errors it displays are as follows.
"Received an unexpected EOF or 0 bytes from the transport stream."
"The Underlying connection was closed: An unexpected error occurred on a send."
My AWB is up to date, and doesn't display this error with my test site.

Event Timeline

Hi @YellowStahh, thanks for taking the time to report this!
Please always include exact version information in bug reports.

Aklapper renamed this task from AWB error connecting to AWB error connecting to miraheze: "Received an unexpected EOF or 0 bytes from the transport stream.".Oct 8 2018, 3:15 PM
Reedy added a comment.Oct 8 2018, 3:20 PM

My AWB is up to date, and doesn't display this error with my test site.

As above, this isn't useful.

I would suggest that as miraheze only seems to support TLS 1.2 (not TLS 1.0 or 1.1), you need to upgrade from 5.10.1.0 to 6.0.0.1 which brings newer TLS support, but also requires .NET 4.5

My AWB is up to date, and doesn't display this error with my test site.

As above, this isn't useful.
I would suggest that as miraheze only seems to support TLS 1.2 (not TLS 1.0 or 1.1), you need to upgrade from 5.10.1.0 to 6.0.0.1 which brings newer TLS support, but also requires .NET 4.5

Thanks for the help, going to 6.0.0.1 seems to have corrected the issue.

Rjwilmsi closed this task as Resolved.Oct 12 2018, 10:24 AM
Rjwilmsi claimed this task.