Page MenuHomePhabricator

Change ProofreadPage's PageDifferenceEngine to use SlotDiffRenderer
Closed, DuplicatePublic

Description

Found the followign message in the log of it.wikisource.org:

[{exception_id}] {exception_url} Exception from line 1243 of /srv/mediawiki/php-1.32.0-wmf.24/includes/diff/DifferenceEngine.php: ProofreadPage\Page\PageDifferenceEngine: could not maintain backwards compatibility. Please use a SlotDiffRenderer.

This occurred only two times over the last 24 hours, but it non the less indicates a problem with the code of ProofreadPage.