Page MenuHomePhabricator

1.33.0-wmf.12 deployment blockers
Closed, ResolvedPublicRelease

Details

Release Version
1.33.0-wmf.12
Release Date
1546819200

2019 week 02 1.33-wmf.12 Changes wmf/1.33.0-wmf.12

This MediaWiki Train Deployment is scheduled for the week of Monday, January 7th:

Monday January 7thTuesday, January 8thWednesday, January 9thThursday, January 10thFriday
SWAT deployments only.Branch wmf.12 and deploy to Group 0 Wikis.Deploy wmf.12 to Group 1 Wikis.Deploy wmf.12 to all Wikis.No deployments on fridays

How this works

  • Any serious bugs affecting wmf.12 should be added as subtasks beneath this one.
  • Any open subtask(s) block the train from moving forward.This means no further deployments until the blockers are resolved.
  • If something is serious enough to warrant a rollback then you should bring it to the attention of deployers on the #wikimedia-operations IRC channel.
  • For more info about deployment blockers, see Holding the train.

Related Links

Other Deployments

Previous: 1.33.0-wmf.11
Next: 1.33.0-wmf.13

Event Timeline

greg created this task.Oct 10 2018, 5:23 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 10 2018, 5:23 PM
greg triaged this task as Normal priority.Oct 10 2018, 7:26 PM
dduvall closed this task as Resolved.Jan 10 2019, 8:59 PM
dduvall claimed this task.
dduvall added a subscriber: dduvall.

Today's all-wiki deployment went much like yesterday's: We saw an increase in the MediaWiki error rate due to a flood of "timed out" errors and what seemed like a side effect of 500s caused by nginx/apache/hhvm socket timeouts. The rate increases lasted from approximately 20:11 until 20:34 UTC at which point they subsided to pre-deployment levels.