Page MenuHomePhabricator

1.33.0-wmf.21 deployment blockers
Closed, ResolvedPublicRelease

Details

Release Version
1.33.0-wmf.21
Release Date
1552262400

2019 week 11 1.33-wmf.21 Changes wmf/1.33.0-wmf.21

This MediaWiki Train Deployment is scheduled for the week of Monday, March 11th:

Monday March 11thTuesday, March 12thWednesday, March 13thThursday, March 14thFriday
SWAT deployments only.Branch wmf.21 and deploy to Group 0 Wikis.Deploy wmf.21 to Group 1 Wikis.Deploy wmf.21 to all Wikis.No deployments on fridays

How this works

  • Any serious bugs affecting wmf.21 should be added as subtasks beneath this one.
  • Any open subtask(s) block the train from moving forward.This means no further deployments until the blockers are resolved.
  • If something is serious enough to warrant a rollback then you should bring it to the attention of deployers on the #wikimedia-operations IRC channel.
  • For more info about deployment blockers, see Holding the train.

Related Links

Other Deployments

Previous: 1.33.0-wmf.20
Next: 1.33.0-wmf.22

Event Timeline

greg created this task.Oct 10 2018, 5:23 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 10 2018, 5:23 PM
greg triaged this task as Normal priority.Oct 10 2018, 7:26 PM

1.33.0-wmf.21 at group 0 (sal, gerrit, mediawiki).

1.33.0-wmf.21 at group 1 (sal, gerrit, mediawiki).

1.33.0-wmf.21 everywhere (sal, gerrit, mediawiki).

herron added a subscriber: herron.Mar 14 2019, 4:05 PM

There looks to be a significant increase (about 1.5 million in the past hour) of log messages from the mediawiki "deprecated" channel to the effect of Use of ParserOutput::getModuleScripts was deprecated in MediaWiki 1.33. Could we squelch these somehow?

https://logstash.wikimedia.org/goto/209aa2ecdcad0527bba0081f33f339a2

Argh, caused by ParsoidBatchAPI which I didn't spot. Patch coming.

Change 496483 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/ParsoidBatchAPI@master] Drop use of getModuleScripts, empty and now hard-deprecated

https://gerrit.wikimedia.org/r/496483

I'm not sure yet what to make out of T218310: "Bad title" message when publishing page: "The requested page title contains invalid characters: "%D7"." (missing exact repro steps, how often it happens, etc) but mentioning it here, just in case.

Change 496483 merged by jenkins-bot:
[mediawiki/extensions/ParsoidBatchAPI@master] Drop use of getModuleScripts, empty and now hard-deprecated

https://gerrit.wikimedia.org/r/496483

Change 496498 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/ParsoidBatchAPI@wmf/1.33.0-wmf.21] Drop use of getModuleScripts, empty and now hard-deprecated

https://gerrit.wikimedia.org/r/496498

Change 496498 merged by jenkins-bot:
[mediawiki/extensions/ParsoidBatchAPI@wmf/1.33.0-wmf.21] Drop use of getModuleScripts, empty and now hard-deprecated

https://gerrit.wikimedia.org/r/496498

Mentioned in SAL (#wikimedia-operations) [2019-03-14T17:59:34Z] <jforrester@deploy1001> Synchronized php-1.33.0-wmf.21/extensions/ParsoidBatchAPI/includes/ApiParsoidBatch.php: Hot-deploy I2842dfea to reduce deprecation spam after T206675 deploy of wmf.21 (duration: 00m 49s)

There looks to be a significant increase (about 1.5 million in the past hour) of log messages from the mediawiki "deprecated" channel to the effect of Use of ParserOutput::getModuleScripts was deprecated in MediaWiki 1.33. Could we squelch these somehow?
https://logstash.wikimedia.org/goto/209aa2ecdcad0527bba0081f33f339a2

That's now fixed, but the new glut of PasswordPolicyChecks::checkPopularPasswordBlacklist deprecations is a different thing which I'm looking at.

I'm not sure yet what to make out of T218310: "Bad title" message when publishing page: "The requested page title contains invalid characters: "%D7"." (missing exact repro steps, how often it happens, etc) but mentioning it here, just in case.

Looks like it's stalled, so I guess it's not blocking the train?

There looks to be a significant increase (about 1.5 million in the past hour) of log messages from the mediawiki "deprecated" channel to the effect of Use of ParserOutput::getModuleScripts was deprecated in MediaWiki 1.33. Could we squelch these somehow?
https://logstash.wikimedia.org/goto/209aa2ecdcad0527bba0081f33f339a2

I was not aware of that dashboard. Should it be added to the list of things train conductor should be monitoring?

https://wikitech.wikimedia.org/wiki/Heterogeneous_deployment/Train_deploys#Places_to_Watch_for_Breakage

That's now fixed, but the new glut of PasswordPolicyChecks::checkPopularPasswordBlacklist deprecations is a different thing which I'm looking at.

Is there a task? (Could not find it.) Should it be added as a blocker?

zeljkofilipin added subscribers: aaron, Catrope, Krinkle.EditedMar 15 2019, 1:47 PM

I'm not sure if this is a blocker: Wikitech-l: Unbreak now! problem in this week train Watchlist.

@Catrope said that it might be caused by 416198. cc @Krinkle @aaron

I was not aware of that dashboard. Should it be added to the list of things train conductor should be monitoring?
https://wikitech.wikimedia.org/wiki/Heterogeneous_deployment/Train_deploys#Places_to_Watch_for_Breakage

The logstash link above might be too specific since it only displays channel:deprecated, but I would say it is worthwhile to monitor overall log volumes for significant changes here https://grafana.wikimedia.org/d/000000102/production-logging

That's now fixed, but the new glut of PasswordPolicyChecks::checkPopularPasswordBlacklist deprecations is a different thing which I'm looking at.

Is there a task? (Could not find it.) Should it be added as a blocker?

T218359 -> T151425. No.

The logstash link above might be too specific since it only displays channel:deprecated, but I would say it is worthwhile to monitor overall log volumes for significant changes here https://grafana.wikimedia.org/d/000000102/production-logging

Thanks for the link! Done!

zeljkofilipin closed this task as Resolved.Mar 18 2019, 9:48 AM