Page MenuHomePhabricator

Implement ‘Event Summary’ downloadable Wikitext report
Closed, ResolvedPublic2 Estimated Story Points

Description

The Event Summary downloadable Wikitext report provides event organizers with a quick way to share top-line event data on wiki. In addition to the data/metrics, the Wikitext report will contain some descriptive information about the event and report; see below under Descriptive Info

  • Metric definitions: This report presents a subset of the metrics defined in T205561, which describes the CSV version of the Pages Created report. Metric definitions for both reports are the same.
  • Some minimal descriptive information about the event is built into the wikitext table. See the mockup and below under Descriptive info

Report Content

Metrics/column names

  • The left-most column of the report will be a the list of metrics below. In other words, this will be a two-column report: one column for labels and a second column for data.
  • Non-sortable columns: Because of the above, there is no need for the columns to be sortable (unlike other Event Summary Wikitext tables, which are sortable).
  • TABLE MOCKUP: For wikitext styling follow the link to a sample table (screenshot below)

The labels for each row will be, in order (pls use this approved wording):

  • Participants [method defined in T208546]
  • Pages created
  • Pages improved
  • Bytes changed [method defined in T206820]
  • Files uploaded [method defined in T206819]
  • Wikidata items created [method defined in T206818]
  • Wikidata items improved [method defined in T206818]
  • Views to pages created [method defined in T206817]
  • Avg. daily views to pages improved [method defined in T206817]
  • Unique pages with uploaded files [method defined in T215356]
  • Avg. daily views to files uploaded [method defined in T206700; also in T206819]!!

Descriptive info

At the top of the table, provide the following information. See mockup for design and layout.

Related Objects

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
jmatazzoni renamed this task from Implement ‘Event Summary’ downloadable Wikitext report to Implement ‘Event Summary’ downloadable Wikitext report.Jan 18 2019, 11:06 PM
jmatazzoni updated the task description. (Show Details)
jmatazzoni updated the task description. (Show Details)
jmatazzoni updated the task description. (Show Details)
MusikAnimal edited projects, added Community-Tech-Sprint; removed Grant-Metrics.

Per T205561#4904504 I'm going to take on this now so that the newer metrics (e.g. T206817) can be tested by product/QA. My plan for now is to just make the endpoint available as with /programs/:id/events/:id/summary?format=wikitext, so you can manually browse to it. If we want we can expose a link to it in the UI, too.

MusikAnimal moved this task from Needs Review/Feedback to QA on the Community-Tech-Sprint board.EditedJan 31 2019, 12:02 AM

@jmatazzoni Ready for review! To use, go to the Event Summary page and add /summary?format=wikitext to the URL. For instance, https://eventmetrics-dev.wmflabs.org/programs/81/events/141/summary

T206819 and T206692 are both awaiting Product/QA review and can now be tested using the Event Summary report. You may need to "Update data" again to get all the new metrics.

jmatazzoni added a comment.EditedJan 31 2019, 10:57 PM

@MusikAnimal I downloaded a couple of reports and was able to confirm that the metrics with [x] in the Description have been implemented. Here are corrections for what I can see. (Moving this back to In Development)

Formatting
  • Table style: please match style of Prateek's model table (with gridlines, etc.)
  • Title: please use dot instead of dash between title and event name, as per Prateek's model.
  • Data snapshot line: should be italic, as per model.
  • About these figures link is missing. See mockup. Here is the URL of the page this link should go to https://meta.wikimedia.org/wiki/Event_Metrics/Definitions_of_metrics
Labels
  • Items created should be "Wikidata items created"
  • Items improved should be "Wikidata items improved"
Metrics issues
  • Views to pages improved is not a metric in this report. I can't tell if this metric is wrong or if it is just mislabeled. The metric should be "Avg. daily views to pages improved" (see T205561 for definition)
  • Bytes added should be "Bytes changed." Same question as above: is this mislabeled or is it the wrong metric?
  • Need +/- for Bytes changed The definition calls for a + or - for this, since it could theoretically be negative.

PR https://github.com/wikimedia/eventmetrics/pull/175

Just to note, I didn't put the heading within the table as was done in the mockup. This won't look so good if the event has a long name, or if translations make the text long. It also isn't tabular data so semantically it wouldn't belong in a table. The other thing I did was make the datestamp in ISO 8601, to match how it appears elsewhere in the application. "5:30pm on 2 September 2018" may not make sense in other locales, and would unnecessarily require a new i18n message. Hope this is okay! Everything else should look the same now (once the code is merged).

MaxSem added a subscriber: MaxSem.Feb 5 2019, 12:34 AM

^ is merged.

Thanks Max!

@jmatazzoni The corrected report is now live. There is one remaining issue: I didn't localize the "Data snapshot" message. Is it okay if we use the existing message "Last updated" as you see on the Event Summary page? This would be for both consistency and reducing the burden on translators.

In T206692#4926181, @MusikAnimal wrote:

...There is one remaining issue: I didn't localize the "Data snapshot" message. Is it okay if we use the existing message "Last updated" as you see on the Event Summary page? This would be for both consistency and reducing the burden on translators.

Yes, that data snapshot is good. If I understand you, it is exactly the same as what is on the last report. I will change all the specs so that is the requirement.

See my checklist above. Everything looks good except:

  • Views to pages improved is not a metric in this report. I can't tell if this metric is wrong or if it is just mislabeled. The metric should be "Avg. daily views to pages improved" (see T205561 for definition)

I'm pretty sure @Samwilson said that this is, indeed, the correct Avg. daily views metric, not the total views to pages improved (right sam?). So if that is indeed true, then all you need to do is change the label to Avg. daily views to pages improved.

MusikAnimal added a comment.EditedFeb 5 2019, 1:50 AM

...There is one remaining issue: I didn't localize the "Data snapshot" message. Is it okay if we use the existing message "Last updated" as you see on the Event Summary page? This would be for both consistency and reducing the burden on translators.

Yes, that data snapshot is good. If I understand you, it is exactly the same as what is on the last report. I will change all the specs so that is the requirement.

To be clear, I was asking if it's okay to say "Last updated [timestamp]" rather than "Data snapshot at [timestamp]". Let me know if it isn't!

...There is one remaining issue: I didn't localize the "Data snapshot" message. Is it okay if we use the existing message "Last updated" as you see on the Event Summary page? This would be for both consistency and reducing the burden on translators.

Yes, that data snapshot is good. If I understand you, it is exactly the same as what is on the last report. I will change all the specs so that is the requirement.

To be clear, I was asking if it's okay to say "Last updated [timestamp]" rather than "Data snapshot at [timestamp]". Let me know if it isn't!

Oh, I didn't get that. Yes, that's fine. Just reproduce the update message from the program in form and content. (At one point I'd said that the timezone should be the that of the downloader, not the event's. But I'm over that and it should just be the event's. I thought you were talking about that.)

@MusikAnimal , putting this back to In Development so you can fix that last labeling issue (see red-icon item above).

jmatazzoni added a comment.EditedFeb 5 2019, 4:53 PM

@MusikAnimal, re. the timestamp, here is what I've written and will copy to other Wikitext report specs.

Last updated yyyy-mm-dd hh:mm (timezone-country/city) [Note: this is the time of the last Update and the timezone of the event, in the same format as on the Event Metrics pages.]

Is this what you wanted? It's not what I'm seeing on the report at present.

@MusikAnimal, I see that T206819 is merged. That means you should be able to add the metric Pages with Uploaded Files to the report.

jmatazzoni updated the task description. (Show Details)
MusikAnimal updated the task description. (Show Details)Feb 14 2019, 12:50 AM

Merged. I'm not sure this needs QA (to save time) -- most of the stats reported are the same shown on the Event Summary page. The ones that aren't can be QA'd in their respective tickets, e.g. T206817. Please move back to QA if you disagree, I just figure it's a lot to review when most of it has been reviewed already (albeit by us before we had a QA engineer).

The message above the table still says "Last updated", per T206692#4926352. If we want this changed, just say so, but note it will change on the Event Summary page, too.

jmatazzoni added a subscriber: dom_walden.EditedFeb 18 2019, 10:53 PM

@MusikAnimal @dom_walden I just pulled a Wikitext table based on this Test report, which I designed to have at least one of everything. The test Wikitext table is here, dated 2-18. The thing is, I don't see any difference between this table and the table on the same page that I did on 2-4. E.g.,

  • The label still says "Views to pages improved" instead of " Avg. daily views to pages improved"
  • Also it's not clear that that is Avg. daily views, since the number is very large. It could be...
  • The label at top still says "data snapshot," and I know Leon wanted to change that.

I know Leon worked on these and Dom tested.... What am I missing here?

@jmatazzoni Perhaps the production version is out of date. Try the same (I think) event on dev: https://eventmetrics-dev.wmflabs.org/programs/76/events/259

The wikitext report on dev has:

  • Participants
  • New Editors (this is shown in the mockup)
  • Pages created
  • Pages improved
  • Bytes changed
  • Files uploaded
  • Wikidata items created
  • Wikidata items improved
  • Views to pages created
  • Avg. daily views to pages improved
  • Unique pages with uploaded files
  • Avg. daily views to files uploaded

It has "Participants" twice in the wikitext table. I am guessing the second should be "New Editors" instead.

In T206692#4963802, @dom_walden wrote:

@jmatazzoni Perhaps the production version is out of date.

Of course. I was so excited to get into EM that I forgot I need to do testing on Test.

I've checked the "Last updated" off in the Description; the table now matches that spec.

  • New Editors (this is shown in the mockup)

New Editors is a field in the CSV version of this report but not on the Wiitext report (because it is generally not a figure that organizers care to show off).

It has "Participants" twice in the wikitext table. I am guessing the second should be "New Editors" instead.

Nope. That is just a mistake; the duplicate needs to be removed. Moving this back to In Dev so @MusikAnimal can take care of that detail.

Nope. That is just a mistake; the duplicate needs to be removed. Moving this back to In Dev so @MusikAnimal can take care of that detail.

Done as part of T216523, same issue. PR at https://github.com/wikimedia/eventmetrics/pull/189. After T208546, the participant count is stored in our database, so it is shown automatically in the views. Hence we needed to remove the manual display of it.

Okay, PR 189 was merged. Moving this straight to product sign-off, since the only thing different is the extraneous Participants count.

Waiting only for Dom to Resolve T206700, so we can declare that 'Avg. daily views to files uploaded' is complete and resolve this ticket too.

jmatazzoni closed this task as Resolved.Mar 4 2019, 6:27 PM

Closing this—our first report complete! Way to go Leon.