Page MenuHomePhabricator

cannot add cloudvirt1023 eth1 to cloud-instances2-b-eqiad vlan
Closed, ResolvedPublic

Description

This task will track the issue of adding cloudvirt1023 (and cloudvirt1024) eth1 to cloud-instances2-b-eqiad.

@RobH initially put cloudvirt1023:eth1 in cloud-instances1-b-eqiad (vlan 1102), but that is not correct. It seems it needs to exist in cloud-instances2-b-eqiad (vlan 1105), but that vlan doesn't tab complete or seem to work when attempting to add ports to it.

When I go to 'set interface-range vlan-' it won't tab complete with cloud-instances2-b-eqiad, only allowing the instances1 vlan to be selected.

Related Objects

StatusSubtypeAssignedTask
ResolvedAndrew
Resolvedfaidon

Event Timeline

RobH triaged this task as High priority.Oct 12 2018, 6:04 PM
RobH created this task.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 12 2018, 6:04 PM
aborrero renamed this task from cannot add cloudvirt1023 eth1 to cloud-instances1-b-eqiad vlan to cannot add cloudvirt1023 eth1 to cloud-instances2-b-eqiad vlan.Oct 12 2018, 6:06 PM
aborrero updated the task description. (Show Details)
RobH added a comment.Oct 12 2018, 6:06 PM

So the vlans show:

default-switch          cloud-instances1-b-eqiad 1102     
                                                           ae3.0*
                                                           ge-2/0/21.0*
                                                           ge-3/0/15.0
                                                           ge-3/0/17.0
                                                           ge-3/0/19.0*
                                                           ge-3/0/37.0
                                                           ge-3/0/38.0
                                                           ge-3/0/39.0
                                                           ge-4/0/12.0
                                                           ge-4/0/36.0
                                                           ge-5/0/21.0
                                                           ge-5/0/22.0
                                                           ge-5/0/23.0
                                                           ge-5/0/3.0
                                                           ge-7/0/11.0
                                                           ge-8/0/13.0
                                                           ge-8/0/24.0
                                                           xe-2/0/22.0*
                                                           xe-4/0/33.0*
                                                           xe-4/0/35.0*
                                                           xe-4/0/45.0*
                                                           xe-4/0/46.0*
                                                           xe-7/0/14.0*
                                                           xe-7/0/17.0*
                                                           xe-7/0/19.0*

default-switch          cloud-instances2-b-eqiad 1105     
                                                           ge-2/0/21.0*
                                                           ge-3/0/15.0
                                                           ge-3/0/17.0
                                                           ge-3/0/37.0
                                                           ge-3/0/38.0
                                                           ge-3/0/39.0
                                                           ge-4/0/12.0
                                                           ge-4/0/36.0
                                                           ge-5/0/21.0
                                                           ge-5/0/22.0
                                                           ge-5/0/23.0
                                                           ge-5/0/3.0
                                                           ge-7/0/11.0
                                                           ge-8/0/13.0
                                                           xe-2/0/22.0*
                                                           xe-4/0/33.0*
                                                           xe-4/0/35.0*
                                                           xe-4/0/45.0*
                                                           xe-4/0/46.0*
                                                           xe-7/0/14.0*
                                                           xe-7/0/17.0*
                                                           xe-7/0/19.0*

Systems exist in the second vlan, so its odd it doesn't tab complete or allow me to add to it?

RobH added a comment.Oct 12 2018, 6:12 PM

So to show the output:

robh@asw2-b-eqiad> show interfaces descriptions | grep cloudvirt1023 
ge-1/0/8        up    up   cloudvirt1023 eth0
ge-1/0/10       up    up   cloudvirt1023 eth1

robh@asw2-b-eqiad> edit 
Entering configuration mode
{master:2}[edit]
robh@asw2-b-eqiad# edit interfaces 

robh@asw2-b-eqiad# set interface-range vlan-   
error: invalid value: vlan-

                                            ^
invalid interface-range name, it shouldn't be any interface-name at 'vlan-'

Possible completions:
  <interface-range-name>  Interface-range name
  vlan-analytics1-b-eqiad  Interface-range name
  vlan-cloud-hosts1-b-eqiad  Interface-range name
  vlan-cloud-instances1-b-eqiad  Interface-range name
  vlan-private1-b-eqiad  Interface-range name
  vlan-public1-b-eqiad  Interface-range name
  vlan-sandbox1-b-eqiad  Interface-range name
{master:2}[edit interfaces]

So the cloud-instances2-b-eqiad doesnt show in tab complete.

I can manually enter it, but then it makes a new stanza in the config, which also isn't right:

robh@asw2-b-eqiad# set interface-range vlan-cloud-instances2-b-eqiad member ge-1/0/10 

{master:2}[edit interfaces]
robh@asw2-b-eqiad# top 

{master:2}[edit]
robh@asw2-b-eqiad# show | compare 
[edit interfaces]
    interface-range cloud-net-trunk { ... }
+   interface-range vlan-cloud-instances2-b-eqiad {
+       member ge-1/0/10;
+   }

{master:2}[edit]
robh@asw2-b-eqiad#
Papaul added a subscriber: Papaul.Oct 12 2018, 6:15 PM
papaul@asw2-b-eqiad# ...eqiad unit 0 family ethernet-switching vlan members cloud-   

{master:2}[edit]
papaul@asw2-b-eqiad# show | compare 
[edit interfaces]
    interface-range cloud-net-trunk { ... }
+   interface-range vlan-cloud-instances2-b-eqiad {
+       member ge-1/0/10;
+       unit 0 {
+           family ethernet-switching {
+               vlan {
+                   members cloud-instances2-b-eqiad;
+               }
+           }
+       }
+   }
RobH added a comment.Oct 12 2018, 6:20 PM
This comment was removed by RobH.
RobH added a comment.Oct 12 2018, 6:34 PM
papaul@asw2-b-eqiad# ...eqiad unit 0 family ethernet-switching vlan members cloud-   
{master:2}[edit]
papaul@asw2-b-eqiad# show | compare 
[edit interfaces]
    interface-range cloud-net-trunk { ... }
+   interface-range vlan-cloud-instances2-b-eqiad {
+       member ge-1/0/10;
+       unit 0 {
+           family ethernet-switching {
+               vlan {
+                   members cloud-instances2-b-eqiad;
+               }
+           }
+       }
+   }

Should we have to add this when systems are already in the vlan?

faidon closed this task as Resolved.Oct 12 2018, 7:37 PM
faidon claimed this task.

FWIW, this was sorted out for both cloudvirt1023 and cloudvirt1024 in exactly the way Papaul suggested.

thanks all!

Would you expect us to need to reinstall the OS (or otherwise make interface changes) after this change?

RobH added a comment.Oct 12 2018, 7:53 PM

I wouldn't think so, nope. The OS install doesn't really make use of eth1...

aborrero reopened this task as Open.Oct 12 2018, 8:11 PM

This still doesn't work. Same behavior as before: packets go out of the interface but nothing enters, which may indicate a miscommunication somewhere in the switching stack.

From netbox, I see this is the first cloudvirt in the B1 rack using the asw2-b1-eqiad switch, which led me to the question if vlan 1105 is trunked between all the switches in row B. I would compare the config with asw2-b4-eqiad and asw2-b7-eqiad, those switches are working with regards to vlan 1105.

I checked the other cloudvirt node that are working (1021,1020 and 1022) all of their eth1 is part of the interface-range cloud-virt-instance-trunk and cloudvirt1023 eth1 is not in that ranges . since vlan cloud-instances2-b-eqiad is member of interface-range cloud-virt-instance-trunk and cloudvirt1023 needs to be in vlan cloud-instances2-b-eqiad, we need to delete ge-1/0/10 from interface-range vlan-cloud-instances2-b-eqiad and put it in interface-range cloud-virt-instance-trunk

interface-range cloud-virt-instance-trunk {
    member ge-3/0/15;                   
    member ge-4/0/12;                   
    member ge-7/0/11;                   
    member ge-8/0/13;                   
    member ge-5/0/3;                    
    member ge-2/0/21;                   
    member ge-4/0/36;                   
    member ge-3/0/17;                   
    member xe-4/0/45;                   
    member xe-2/0/22;                   
    member xe-4/0/35;                   
    member xe-7/0/17;            this is cloudvirt1022 eth1       
    member ge-7/0/14;           this is cloudvirt1020    eth1     
    member xe-4/0/33;            this is cloudvirt1021   eth1    
    member xe-7/0/14;         

unit 0 {                            
        family ethernet-switching {     
            interface-mode trunk;       
            vlan {                      
                members [ cloud-instances1-b-eqiad cloud-instances2-b-eqiad ];
            }                           
        }                               
    }
faidon closed this task as Resolved.Oct 12 2018, 11:32 PM

I checked the other cloudvirt node that are working (1021,1020 and 1022) all of their eth1 is part of the interface-range cloud-virt-instance-trunk and cloudvirt1023 eth1 is not in that ranges . since vlan cloud-instances2-b-eqiad is member of interface-range cloud-virt-instance-trunk and cloudvirt1023 needs to be in vlan cloud-instances2-b-eqiad, we need to delete ge-1/0/10 from interface-range vlan-cloud-instances2-b-eqiad and put it in interface-range cloud-virt-instance-trunk

…and @Papaul was right again :) We had a long chat on IRC with @aborrero in order for me to understand this better. The longer version is that is that cloudvirt* expect the port to be trunk (carry 802.1q frames), while the configuration on the switch above was configured as access. We had a long discussion about it, and basically it gists down to having a common configuration for both the old nodes (with the compat network VLAN, i.e. cloud-instances1-b-eqiad) and the new network (cloud-instances2-b-eqiad) so that cloudvirt servers can be migrated at will.

I did basically just what Papaul also suggested above and moved cloudvirt1023/4 to cloud-virt-instance-trunk. @Andrew confirmed that connectivity was restored.