Page MenuHomePhabricator

Job cirrusSearchLinksUpdatePrioritized failures "Call to getNamespace() on a non-object"
Closed, ResolvedPublic

Description

Error

Request ID: 3584b53c765c52d29a99f42d

message
BadMethodCallException: Call to a member function getNamespace() on a non-object (null)

[{exception_id}] {exception_url} from line 520 of /srv/mediawiki/php-1.32.0-wmf.24/extensions/CirrusSearch/includes/Updater.php
trace
#0 /srv/mediawiki/php-1.32.0-wmf.24/extensions/CirrusSearch/includes/Updater.php(360): CirrusSearch\Updater::extractDisplayTitle(Title, ParserOutput)
#1 /srv/mediawiki/php-1.32.0-wmf.24/extensions/CirrusSearch/includes/Updater.php(407): CirrusSearch\Updater::buildDocument(CirrusSearch, WikiPage, CirrusSearch\Connection, integer, integer, integer)
#2 /srv/mediawiki/php-1.32.0-wmf.24/extensions/CirrusSearch/includes/Updater.php(205): CirrusSearch\Updater->buildDocumentsForPages(array, integer)
#3 /srv/mediawiki/php-1.32.0-wmf.24/extensions/CirrusSearch/includes/Updater.php(84): CirrusSearch\Updater->updatePages(array, integer)
#4 /srv/mediawiki/php-1.32.0-wmf.24/extensions/CirrusSearch/includes/Job/LinksUpdate.php(52): CirrusSearch\Updater->updateFromTitle(Title)
#5 /srv/mediawiki/php-1.32.0-wmf.24/extensions/CirrusSearch/includes/Job/Job.php(99): CirrusSearch\Job\LinksUpdate->doJob()
#6 /srv/mediawiki/php-1.32.0-wmf.24/extensions/EventBus/includes/JobExecutor.php(65): CirrusSearch\Job\Job->run()
#7 /srv/mediawiki/rpc/RunSingleJob.php(67): JobExecutor->execute(array)

Impact

Unknown.

Notes

Captured 152 times in Logstash in the last 30 days. Seems to happen in bursts, possibly due to it (consistently) happening after certain page actions are performed.

The burst made it appear like a regression from a specific deployment, when actually it had been dormant for a few days and just happened to pop up.

Event Timeline

Krinkle created this task.Oct 15 2018, 12:43 AM
Restricted Application added a project: Discovery-Search. · View Herald TranscriptOct 15 2018, 12:43 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
dcausse claimed this task.Oct 25 2018, 8:25 AM
dcausse triaged this task as Medium priority.
dcausse moved this task from needs triage to Up Next on the Discovery-Search board.
dcausse added a subscriber: dcausse.

This code is relatively new it's probable that it's not aware of all the scenario, I will take a look.

Change 469615 had a related patch set uploaded (by DCausse; owner: DCausse):
[mediawiki/extensions/CirrusSearch@master] Don't try to detect the namespace prefix

https://gerrit.wikimedia.org/r/469615

Change 469615 merged by jenkins-bot:
[mediawiki/extensions/CirrusSearch@master] Don't try to detect the namespace prefix

https://gerrit.wikimedia.org/r/469615

Change 470223 had a related patch set uploaded (by Krinkle; owner: DCausse):
[mediawiki/extensions/CirrusSearch@wmf/1.33.0-wmf.1] Don't try to detect the namespace prefix

https://gerrit.wikimedia.org/r/470223

Change 470223 merged by jenkins-bot:
[mediawiki/extensions/CirrusSearch@wmf/1.33.0-wmf.1] Don't try to detect the namespace prefix

https://gerrit.wikimedia.org/r/470223

Mentioned in SAL (#wikimedia-operations) [2018-10-28T00:03:11Z] <krinkle@deploy1001> Synchronized php-1.33.0-wmf.1/extensions/CirrusSearch: T206967 - Ia23d19cf1e6 (duration: 01m 02s)

Krinkle closed this task as Resolved.Oct 28 2018, 12:03 AM
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:08 PM