Page MenuHomePhabricator

Add an unique CSS class or ID to the tagfilter table row at RecentChanges
Closed, ResolvedPublic

Description

Author: Wiki.Melancholie

Description:
Add an unique CSS class or ID to the tagfilter table row at [[Special:RecentChanges]]:
<tr><td class="mw-label"><a href="/wiki/Special:Tags" title="Special:Tags">Tag</a> filter:</td><td class="mw-input"><input name="tagfilter" size="20" value="" /> <input type="submit" value="Go" /></td></tr>

That would allow to hide that input field (a whole new line taking space, doesn't float right) for wikis/users where this either isn't needed or not used. Currently an ugly JS hack would have to be used.


Severity: enhancement
URL: http://en.wikipedia.org/wiki/Special:RecentChanges

Details

Reference
bz18704

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 10:33 PM
bzimport set Reference to bz18704.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.May 7 2009, 12:03 PM

Changed Component; main tags functionality is powered by the MW system, Abuse filter just uses it from my understanding.

Wiki.Melancholie wrote:

Oh, the submit button should not be hidden (in second row); thus either move the submit button into the previous table row (best), or just give the tagfilter input the appropriate ID/class.

The actual html (and the place to add classes) is in abuse filter. Not really related to tags.

Updated component.

  • Bug 19568 has been marked as a duplicate of this bug. ***
Ireas added a comment.Sep 22 2009, 7:07 PM

Created attachment 6571
adds “tag-filter” id

In this patch, I just added the id “tag-filter” to the input tag.

attachment tagfilter.patch ignored as obsolete

happy.melon.wiki wrote:

Comment on attachment 6571
adds “tag-filter” id

This patch is six thousand revisions out of date; adding this functionality is no longer "easy".

New patch to add classes

Adds 'tagfilter-form' class to standalone version; adds 'tagfilter-input' to input and 'tagfilter-label' to label. Hiding all three in conjunction hides the tagfilter completely, though the interplay with the Submit button is a tricky one.

Classes are cheap, no?

attachment 18704.patch ignored as obsolete

(Oh, and copied and pasted in a GPL header for a file that had none. Hope that's right.)

sumanah wrote:

Jarry1250, I'm sorry -- in the last 9 months, the codebase has changed enough that your patch no longer applies cleanly to trunk. Therefore I'm marking it obsolete and removing the "need-review" and "patch" keywords. If the issue is still one you're interested in fixing, please join us in MediaWiki-General to check in before renewing and possibly revising your approach.

Thanks for the patch nonetheless, and sorry for the delay.

sumanah wrote:

Comment on attachment 8321
New patch to add classes

This patch no longer applies to trunk per Rusty Burchfield's automated testing
https://docs.google.com/spreadsheet/ccc?key=0Ah_71HHl7qa7dGtvSms3TGpHQU9NU2Y1VmNzUEUteWc .

Revised patch

Updated for latest trunk; haven't been able to test but is identical to previous patch, which I was able to test.

Attached:

r111186 -- had to remove a stray comma so it would work.

r111186 was reverted in the end, will resubmit correct version momentarily.

Fix merged as part of the afore-linked change (3659), so closing as FIXED again.

Reedy added a comment.Apr 7 2012, 12:16 AM

https://gerrit.wikimedia.org/r/#change,4494

"It was causing: <b>Notice</b>: Array to string conversion in <b>D:\www\DevWiki\core\includes\actions\HistoryAction.php</b> on line <b>164</b><br />"

Restricted Application added a subscriber: Luke081515. · View Herald TranscriptApr 30 2016, 10:36 AM
Izno added a project: CSS.Sep 7 2018, 4:39 PM
Izno removed a subscriber: wikibugs-l-list.
Izno moved this task from Backlog to Change CSS Hook on the CSS board.Sep 7 2018, 4:48 PM
Krinkle updated the task description. (Show Details)Sep 12 2018, 4:05 AM
Krinkle closed this task as Resolved.Sep 12 2018, 4:09 AM
Krinkle claimed this task.
Krinkle added a subscriber: Krinkle.
Special:RecentChanges
<tr class="tagfilterForm">
  <td class="mw-label mw-tagfilter-label"><label for="tagfilter"><a href="/wiki/Special:Tags" title="Special:Tags">Tag</a> filter:</label></td>
  <td class="mw-input">
  <input name="tagfilter" size="20" value="" class="mw-tagfilter-input mw-ui-input mw-ui-input-inline" id="tagfilter"> <input type="submit" value="Show"></td>
</tr>

The form has a specific CSS class, and the input as well.

Restricted Application added a project: Growth-Team. · View Herald TranscriptSep 12 2018, 4:09 AM