Page MenuHomePhabricator

AssertionError: undefined
Closed, ResolvedPublic

Description

https://logstash.wikimedia.org/app/kibana#/doc/logstash-*/logstash-2018.10.15/parsoid?id=AWZ5iNkRz9bxnQJdAGOw&_g=h@44136fa

enwiki List_of_law_clerks_of_the_Supreme_Court_of_the_United_States 863480284

AssertionError: undefined
    at Console.assert (console.js:95:23)
    at SyncTokenTransformManager.TokenTransformManager._getTransforms (/srv/deployment/parsoid/deploy-cache/revs/b75812466bb203817883cebc01f90d9fc34e1916/src/lib/wt2html/TokenTransformManager.js:242:10)
    at SyncTokenTransformManager.onChunk (/srv/deployment/parsoid/deploy-cache/revs/b75812466bb203817883cebc01f90d9fc34e1916/src/lib/wt2html/TokenTransformManager.js:922:17)
    at emitOne (events.js:96:13)
    at PegTokenizer.emit (events.js:188:7)
    at emitChunk (eval at <anonymous> (/srv/deployment/parsoid/deploy-cache/revs/b75812466bb203817883cebc01f90d9fc34e1916/src/lib/wt2html/tokenizer.js:1:0), <anonymous>:20122:25)
    at peg$c33 (eval at <anonymous> (/srv/deployment/parsoid/deploy-cache/revs/b75812466bb203817883cebc01f90d9fc34e1916/src/lib/wt2html/tokenizer.js:1:0), <anonymous>:390:11)
    at peg$parsetlb (eval at <anonymous> (/srv/deployment/parsoid/deploy-cache/revs/b75812466bb203817883cebc01f90d9fc34e1916/src/lib/wt2html/tokenizer.js:1:0), <anonymous>:3189:12)
    at Object.next (eval at <anonymous> (/srv/deployment/parsoid/deploy-cache/revs/b75812466bb203817883cebc01f90d9fc34e1916/src/lib/wt2html/tokenizer.js:1:0), <anonymous>:1903:14)
    at Immediate.tokenizeChunk (/srv/deployment/parsoid/deploy-cache/revs/b75812466bb203817883cebc01f90d9fc34e1916/src/lib/wt2html/tokenizer.js:301:20)
    at runCallback (timers.js:672:20)
    at tryOnImmediate (timers.js:645:5)
    at processImmediate [as _immediateCallback] (timers.js:617:5)

The page in question is already known as timing out in T206040 but the changes in T187848 are likely the cause of the new assertions since today's deploy.

Event Timeline

Arlolra created this task.Oct 15 2018, 9:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 15 2018, 9:06 PM
Arlolra claimed this task.Oct 16 2018, 5:30 PM

Change 467737 had a related patch set uploaded (by Arlolra; owner: Arlolra):
[mediawiki/services/parsoid@master] Stop suppressing aborting when recursively tokenizing includes

https://gerrit.wikimedia.org/r/467737

Change 467737 merged by jenkins-bot:
[mediawiki/services/parsoid@master] Stop suppressing aborting when recursively tokenizing includes

https://gerrit.wikimedia.org/r/467737

Arlolra closed this task as Resolved.Oct 16 2018, 9:23 PM