Page MenuHomePhabricator

[AzharAuth] AzharAuth/AzharAuth.class.php triggers warnings on PHP 7.3
Closed, ResolvedPublic

Description

PHP Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /srv/mediawiki/core/extensions/AzharAuth/AzharAuth.class.php on line 285

Event Timeline

Legoktm created this task.Oct 16 2018, 2:52 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 16 2018, 2:52 AM
Legoktm moved this task from Backlog to Other on the PHP 7.3 support board.Oct 16 2018, 2:56 AM
Liuxinyu970226 added a subscriber: Liuxinyu970226.

This extension is considering for archival per T198601, still need patch for this?

This extension is considering for archival per T198601, still need patch for this?

If the extension is archived, we can decline this. However I wanted to file tickets for everything as reference.

Change 512916 had a related patch set uploaded (by 星耀晨曦; owner: 星耀晨曦):
[mediawiki/extensions/AzharAuth@master] Use break instead of continue in a switch block

https://gerrit.wikimedia.org/r/512916

Change 512916 merged by jenkins-bot:
[mediawiki/extensions/AzharAuth@master] Use break instead of continue in a switch block

https://gerrit.wikimedia.org/r/512916

RazeSoldier closed this task as Resolved.May 29 2019, 2:11 AM