Page MenuHomePhabricator

Monobook: Low contrast in OO.ui.confirm
Closed, DeclinedPublic

Description

When showing an OO.ui.confirm dialog with the MonoBook skin, the text in the prompt will have the color #666 on a #fff background.

This fails the WCAG AAA standard but at least seems to be is enough for WCAG AA.

Can be seen for example in the "Discard changes" warning in the Two-Column-Edit-Conflict-Merge extension.

Event Timeline

Restricted Application added projects: TCB-Team, Design. · View Herald TranscriptOct 16 2018, 11:51 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Are we following any standards here, e.g. using the color of OOUI (is this even used in monospace?). If this is a general problem, that is reproduced through our feature I would claim to not change anything but rather push for a global change of this issue then. If it is a problem that only occurs in our feature because we used different colors, then let's change it to a more accessible setup.

This seems to be a general issue with Monobook and OOUI. I'll change the ticket accordingly.

WMDE-Fisch renamed this task from Monobook: Low contrast of Warning-Text to Monobook: Low contrast in OO.ui.confirm.Mon, Feb 10, 11:46 AM
WMDE-Fisch edited projects, added MonoBook, OOUI; removed WMDE-Design, Design, TCB-Team.
WMDE-Fisch updated the task description. (Show Details)

The Apex OOUI them (designed to fit in with the MonoBook/Vector/Apex skins, and used in MonoBook) targets WCAG AA, not AAA, yes.

WikimediaUI targets WCAG AAA, and is one of (many) reasons why we don't show the legacy MonoBook design to users except ultra-experts that demand it.

WMDE-Fisch closed this task as Declined.Tue, Feb 11, 10:00 AM

The Apex OOUI them (designed to fit in with the MonoBook/Vector/Apex skins, and used in MonoBook) targets WCAG AA, not AAA, yes.
WikimediaUI targets WCAG AAA, and is one of (many) reasons why we don't show the legacy MonoBook design to users except ultra-experts that demand it.

Ok, that makes sense. Thanks for the explanation. I guess this can be closed now.