Page MenuHomePhabricator

Disable unused Flow extension on de.wikiversity
Closed, ResolvedPublic

Description

On the German Wikiversity, Flow is not used for any page. The one page in the namespace (accordin to https://de.wikiversity.org/w/index.php?title=Spezial:Alle_Seiten&namespace=2600 ) is actually a wikitext page, which the extension has made inaccessible.
https://de.wikiversity.org/wiki/Thema:Was_wir_h%C3%B6ren_und_sehen

Please disable the extension and move back the page to namespace 0.

Event Timeline

Nemo_bis created this task.Oct 22 2018, 7:04 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 22 2018, 7:04 AM
Kizule claimed this task.Nov 12 2018, 7:58 PM
Restricted Application added a project: User-Kizule. · View Herald TranscriptNov 12 2018, 7:58 PM

Change 478463 had a related patch set uploaded (by Zoranzoki21; owner: Zoranzoki21):
[operations/mediawiki-config@master] Disable unused Flow extension on de.wikiversity

https://gerrit.wikimedia.org/r/478463

Kizule moved this task from Inbox to To deploy on the User-Kizule board.Dec 9 2018, 7:53 AM

Change 478463 merged by jenkins-bot:
[operations/mediawiki-config@master] Disable unused Flow extension on de.wikiversity

https://gerrit.wikimedia.org/r/478463

Change 483109 had a related patch set uploaded (by Zfilipin; owner: Zfilipin):
[operations/mediawiki-config@master] Revert "Disable unused Flow extension on de.wikiversity"

https://gerrit.wikimedia.org/r/483109

Change 483109 merged by jenkins-bot:
[operations/mediawiki-config@master] Revert "Disable unused Flow extension on de.wikiversity"

https://gerrit.wikimedia.org/r/483109

Change 483111 had a related patch set uploaded (by Zoranzoki21; owner: Zoranzoki21):
[operations/mediawiki-config@master] Reverted "Revert "Disable unused Flow extension on de.wikiversity""

https://gerrit.wikimedia.org/r/483111

Nemo_bis added a comment.EditedJan 9 2019, 4:26 PM
In T207626#4865526, @Zoranzoki21 wrote:

No. The page already has a wikitext content model. It only needs to be returned to namespace 0 by running the usual namespaceDupes.php.

Change 483111 merged by jenkins-bot:
[operations/mediawiki-config@master] Reverted "Revert "Disable unused Flow extension on de.wikiversity""

https://gerrit.wikimedia.org/r/483111

Mentioned in SAL (#wikimedia-operations) [2019-01-10T12:12:48Z] <zfilipin@deploy1001> Synchronized dblists/flow.dblist: SWAT: [[gerrit:483111|Reverted "Revert "Disable unused Flow extension on de.wikiversity"" (T207626)]] (duration: 00m 53s)

zfilipin@mwmaint1002:~$ mwscript namespaceDupes.php dewikiversity --fix
0 pages to fix, 0 were resolvable.

pagelinks from=18722 ns=0 dbk=Benutzerin:InaMS -> Benutzer:InaMS
pagelinks from=3813 ns=0 dbk=Kurs:Internet-_und_Projektkompetenz/Kurse -> Kurs:Internet-_und_Projektkompetenz/Kurse
2 links to fix, 2 were resolvable.

Looks good!
Kizule closed this task as Resolved.Jan 20 2019, 2:46 PM

Oh, forgot to close this.

ArielGlenn reopened this task as Open.Apr 10 2019, 12:23 PM
ArielGlenn added subscribers: daniel, ArielGlenn.

The inaccessible page is still marked as content type flow-board in the content table, see T220594 for the gory details. This needs to be fixed up though I don't know the best way to do that. I"m going to add @daniel as it's MCR-related and he might have some insight.

In T207626#4865526, @Zoranzoki21 wrote:

No. The page already has a wikitext content model. It only needs to be returned to namespace 0 by running the usual namespaceDupes.php.

I guess this is not quite right. The *page* has a wikitext content model, but the *revisions* (well, more precisely the contents in the slots) have a 'flow-board' model.

See T220594#5100772 and T220594#5101026 for the content model of the slot's content, and the actual text.

https://de.wikiversity.org/wiki/Thema:Was_wir_h%C3%B6ren_und_sehen?uselang=en shows the page is still not accessible.

I think (but cannot be sure) that the right fix is just to change 'flow-board' to 'wikitext' (from 4 to 1) in that one column of the one content entry.

The revision, the only one for the page, was created in 2011 with the unfortunate prefix 'Thema:' while Flow was enabled in 2015 on the wiki.

I guess that the migration to slots/content might have added the 'wrong' content model. The revision predated the content_model field in the rev table, and it may be that the field was empty/null at the time of the migration.

Looking at PopulateContentTables::getContentModel(), this could lead to the value from ContentHandler::getDefaultModelFor( $title ); i.e. 'flow-board', being used to fill in the content row, but no other changes.

So I agree with @daniel in T220594#5100953 that the thing to do is manually fix that field. And once again we are looking for the person to do it. Whoooo shall step up and Be Bold?

I don't think this is going to work. See, currently MW has issues with the page if you request it: https://de.wikiversity.org/wiki/Thema:Was_wir_h%C3%B6ren_und_sehen?uselang=en

If you want the revision (try https://de.wikiversity.org/w/index.php?title=Thema:Was_wir_h%C3%B6ren_und_sehen&oldid=274772&uselang=en )
you get [XTnxNgpAAD0AAFh-21gAAACA] 2019-07-25 18:13:10: Fatal exception of type MWUnknownContentModelException
and that is, as the stack trace tells us, because "The content model 'flow-board' is not registered on this wiki.". That's the very thing I want to fix...

Special:ChangeContentModel validates the page title, and that calls getContentHandler() and that's what fails above as well.

If there is a need for dummy content handler logic, file a ticket and drop it into the core platform inbox. And indicate how urgent it is. I'd say chances are good that something gets done about it "soonish" :)

It looks like there is already such a ticket: T220608 which if I read it correctly would return the raw tex as it appears in the database, for purposes of jobs like the dumps. Should I move this to the Inbox column then?

It looks like there is already such a ticket: T220608 which if I read it correctly would return the raw tex as it appears in the database, for purposes of jobs like the dumps. Should I move this to the Inbox column then?

I just did that.

@ArielGlenn We've managed, with @Urbanecm to get rid of the bad title on this wiki, move it and then delete the page. Can you please verify it's all okay now? Thanks.

MarcoAurelio closed this task as Resolved.Aug 8 2019, 11:14 AM

Confirmed this is now done & looking okay from the dumps side.