Page MenuHomePhabricator

Change the opt-out message for watchlists and recent changes in preferences, to reflect the fact that those features are now default
Closed, ResolvedPublic

Description

The current wording is (for watchlist):


That wording implies that the improvements are an option, while they are now the default settings.

It should be something like:

The same applies for recent changes settings.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 23 2018, 11:54 AM
kostajh added a subscriber: kostajh.

@Trizek-WMF we'll work on this soon. Are you happy with the text change you suggested or do you want to work on that more before it is implemented?

@Trizek-WMF -- let's briefly discuss this in our check-in next week.

@Trizek-WMF we'll work on this soon. Are you happy with the text change you suggested or do you want to work on that more before it is implemented?

A better wording would be certainly welcomed.

@Trizek-WMF -- let's briefly discuss this in our check-in next week.

Sure.

@kostajh -- @Trizek-WMF and I talked about this. We have two changes:

  • It should say "highlighting", not "highlightings".
  • Instead of keeping this option under its own header (e.g. "Opt out of improvements") we should move it under the existing "Advanced options" header on both the Recent Changes and Watchlist preferences pages.

Change 472056 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/core@master] WIP: Update wording for RC and Watchlist UI opt-out option

https://gerrit.wikimedia.org/r/472056

@MMiller_WMF @Trizek-WMF two questions/comments:

  1. In my patch I removed the rcfilters-watchlist-preference-label and rcfilters-watchlist-preference-help messages in en.json and qqq.json, as it just duplicates what is in rcfilters-preference-label and rcfilters-preference-help. But if you think the Watchlist opt out might have different wording from the RC opt out in the future, then we could keep both around.
  2. I'd like to suggest different wording because the non-JavaScript interface does have filters. What do you think about "Use non-Javascript interface" as the checkbox text, with no secondary label?

@MMiller_WMF @Trizek-WMF two questions/comments:

  1. In my patch I removed the rcfilters-watchlist-preference-label and rcfilters-watchlist-preference-help messages in en.json and qqq.json, as it just duplicates what is in rcfilters-preference-label and rcfilters-preference-help. But if you think the Watchlist opt out might have different wording from the RC opt out in the future, then we could keep both around.

I don't think it is necessary to keep a duplicate, while each option is under its own tab. That's an option based on common sense. Is there any development best practice for that?

  1. I'd like to suggest different wording because the non-JavaScript interface does have filters. What do you think about "Use non-Javascript interface" as the checkbox text, with no secondary label?

What about "Disable filters search and highlight function"? This surfaces two key elements that describe the "new filters" the best way. Then people would not be surprised of the result.

I don't think it is necessary to keep a duplicate, while each option is under its own tab. That's an option based on common sense. Is there any development best practice for that?

We could probably go either way. As I'm looking at it again this morning, even though the translated text will be the same, it probably makes more sense to keep distinct label/help message keys since they control separate variables. I'll revise the patch.

What about "Disable filters search and highlight function"? This surfaces two key elements that describe the "new filters" the best way. Then people would not be surprised of the result.

Hmm, I'm not sure. I think it's OK. The thing I'm unsure of is that the way that is phrased (Disable filters search and highlight functionality) , it might confuse the user as to why we would even present this to them as an option, since it seems to take away functionality to no benefit to the user.

Maybe another way to phrase it is:

- [ ] Use minimalist interface
      Loads {RecentChanges/Watchlist} without filters search or highlighting functionality.

With respect to #1, I don't have a preference.

With respect to #2, I think @kostajh's suggestion sounds good, except instead of "minimalist", I think it should say, "non-JavaScript".

Go for:

- [ ] Use non-JavaScript interface
      Loads {RecentChanges/Watchlist} without filters search or highlighting functionality.
kostajh removed kostajh as the assignee of this task.Nov 14 2018, 4:13 PM

I should get to this soon but prioritizing other things today and tomorrow, unassigning myself in case someone else wants it.

Catrope claimed this task.Nov 19 2018, 11:57 PM
Catrope added a subscriber: Catrope.

I've updated the patch and I think it's ready for review now.

Change 472056 merged by jenkins-bot:
[mediawiki/core@master] Update wording for RC and Watchlist UI opt-out option

https://gerrit.wikimedia.org/r/472056

Etonkovidova closed this task as Resolved.Nov 24 2018, 5:28 AM
Etonkovidova added a subscriber: Etonkovidova.

Checked in betalabs - all changes are in place:
Watchlist

Recent Changes

Previously:

@Trizek-WMF - from the suggested wording in your comment, filters search is changed to just filters - is it ok? 'Disable filters' sounds a bit misleading.

Go for:

- [ ] Use non-JavaScript interface
      Loads {RecentChanges/Watchlist} without filters search or highlighting functionality.

@Trizek-WMF - from the suggested wording in your comment, filters search is changed to just filters - is it ok? 'Disable filters' sounds a bit misleading.

In T207741#4726432, @kostajh rightfully noted that non-JS interface has filters. This is why we've used "filters search". I guess that's finally right while Kosta has +2 the change.

Change 475815 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] Preferences: Remove unused message for RC/Watchlist opt-out section

https://gerrit.wikimedia.org/r/475815

Change 475816 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] RCFilters: Tweak opt-out preference description

https://gerrit.wikimedia.org/r/475816

Change 475815 merged by jenkins-bot:
[mediawiki/core@master] Preferences: Remove unused message for RC/Watchlist opt-out section

https://gerrit.wikimedia.org/r/475815

Change 475816 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Tweak opt-out preference description

https://gerrit.wikimedia.org/r/475816