Page MenuHomePhabricator

Special:MyContributions does not accept start or end URL parameters
Closed, ResolvedPublic

Description

I wanted to construct a URL for all the lexemes a user created before a certain date (the deployment of Senses to Wikidata, i. e. lexemes where senses might need to be added) –

https://www.wikidata.org/wiki/Special:MyContributions?namespace=146&newOnly=1&end=2018-10-18&limit=500

– but discovered that, when Special:MyContributions redirects to Special:Contributions/MY_USER_NAME, it discards the end argument. Some investigation turns up the following assignment in the source code:

class SpecialMycontributions extends RedirectSpecialPage {
    public function __construct() {
        parent::__construct( 'Mycontributions' );
        $this->mAllowedRedirectParams = [ 'limit', 'namespace', 'tagfilter',
            'offset', 'dir', 'year', 'month', 'feed', 'deletedOnly',
            'nsInvert', 'associated', 'newOnly', 'topOnly' ];
    }
    # ...
}

Is there any special reason why start and end are not in the allowed redirect parameters, or is it just an oversight?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 24 2018, 9:38 PM

Change 469523 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/core@master] Add start, end to allowed params of Special:MyContributions

https://gerrit.wikimedia.org/r/469523

Change 469523 merged by jenkins-bot:
[mediawiki/core@master] Add start, end to allowed params of Special:MyContributions

https://gerrit.wikimedia.org/r/469523

Lucas_Werkmeister_WMDE closed this task as Resolved.Nov 7 2018, 11:01 PM
Lucas_Werkmeister_WMDE claimed this task.

The fix is merged and deployed, and the URL works as intended now. Closing.