Page MenuHomePhabricator

Proposal: Provide Test Support for Various Wikimedia Projects - Outreachy (Round 17)
Closed, ResolvedPublic

Description

Profile Information

Name: Barb Van Dine
Email: barb.vandine@gmail.com
Web page: http://www.pocobits.com/bvandine
Location: San Francisco Bay Area, US
Typical working hours: 11am to 7pm PDT (6pm to 2am UTC)

Synopsis

The Mediawiki software continually evolves as developers add to and improve its set of tools, features, and extensions. The aim of this project is to support the development process by providing careful, comprehensive testing both before and after changes are introduced, to ensure that new components work as intended and that existing components continue to function as the code base changes.

The specific tasks depend on the development efforts that are underway during the four-month span of the internship, but possible areas of focus include Content Translation, Visual Editor, Notifications, Maps, Page Curation, and Integrated filters (RC and Watchlist).

Mentors: @Etonkovidova, @Ryasmeen

Deliverables

Deliverables will include:

  • Development of test cases for projects as they arise.
  • Archiving test cases for use by others.
  • Executing the test cases and reporting the results, filing bug reports in Phabricator as necessary.
  • Maintaining active collaboration with other test team members as any bug reports I file are evaluated and refined.
  • Tracking the bug reports of other testers who are working on the same project(s), and contributing to the discussion whenever possible.
  • Updating the Help page for a tool, feature, or extension when, in the course of testing, I discover any inaccuracies.
  • Participating in any initiatives to improve QA processes (for example: helping to document QA processes or best practices, helping to archive test cases or upload them to an automation tool, or developing and archiving examples to aid future testers.)

The timeline will depend on the priorities of the development and test teams, however it's likely that the first two or three weeks will be devoted to coming up-to-speed on current QA practices and tools.

Participation

  • My task-related communication will happen mainly on the relevant Phabricator pages.
  • If questions and issues arise, I will communicate with my mentors via email (the preferred mode for our team.)
  • I will send brief, weekly status reports via email to my mentors, so that they know how I'm progressing on the assigned tasks.

About Me

I am an older woman (60) with a bachelor's degree in Liberal Arts from the Pennsylvania State University. For most of my professional life I have been a technical writer, but I was knocked out of the workforce about five years ago when I was struck by a car while out jogging. Now I am trying to broaden my skill set in an effort to attempt reentry. I was doing this in isolation until a friend told me about the Outreachy program, with its emphasis on collaboration and learning by doing. I can't tell you how gratifying it has been to discover that some of the skills I acquired as a technical writer are actually transferable to software testing, or how GREAT it felt to discover and document that first bug (not to mention the second and third!) I would be thrilled to continue learning in an atmosphere where I can actually contribute to real projects.

I do not have any commitments that would interfere with working a forty-hour week.

The only exception is November 22nd & 23rd (Thanksgiving) and December 24 - 26 (Christmas), when I will be offline for the holidays.

Past Experience

The bulk of my past experience has been in technical writing. Technical writing develops a certain attention to detail and focus on step-by-step procedure that will probably come in handy in a testing context.

I have never worked on an Open Source project before (that's part of what attracted me to this program), but the environments where I have worked (chiefly software start-ups) have certain similarities. For example, in most projects I've worked on, the teams were distributed across different time zones and communicated in large part online. Also, the environments were intensely collaborative. The writing, testing, and customer support groups in particular relied on each other to share information and resources.

Any Other Info

Contributions to the testing project so far:

In case it turns out to be relevant to any upcoming testing projects, I want to mention that I have experience with HTML and CSS.

Event Timeline

Barbvd created this task.Oct 25 2018, 5:46 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 25 2018, 5:46 AM
Barbvd updated the task description. (Show Details)Oct 25 2018, 6:14 AM

Thx @Barbvd - I've reviewed the phab task. 'Deliverables' summarize concisely the objectives of QA work in the context of exploratory testing for various projects.

The filed tasks show a good understanding of functionality and present valuable findings that certainly uncovered bugs not were not found before. Also, the filed phab tasks contain full information about found issues with clear description of the steps which makes it easy to reproduce the issues.

@Barbvd Sweet! It is a well-crafted proposal :-)

I would just leave a small comment about participation:

Participation

  • I will send brief, weekly status reports via email to my mentors, so that they know how I'm progressing on the assigned tasks.

We encourage candidates to document their weekly reports on their blog as well every two weeks, hope you would be open to that idea! (See https://www.mediawiki.org/wiki/Outreachy/Participants#Internship_period)

Make sure that you record your contributions that you've listed under "Any other info" section and upload your proposal on Outreachy site in less than 24 hours from now :-) (application deadline is October 30th 16 UTC)

@Barbvd @Etonkovidova Is there anything remaining in this task from Outreachy Round 17? If not, then please consider marking it as resolved!

Ryasmeen closed this task as Resolved.Apr 18 2019, 2:10 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptApr 18 2019, 2:10 AM