Page MenuHomePhabricator

[BUG] Sidebar interwiki linking failed
Closed, DuplicatePublic

Description

This problem pertains to https://zh-yue.wikipedia.org/wiki/加冷河. The sidebar interwiki linking tool is not working. It would stop at the confirmation pop-up and could not display the links to other wikis, ultimately failing to link.

Two tests have been carried out.
After encountering this bug, I tried another article https://zh-yue.wikipedia.org/wiki/劉太格. The tool worked as usual.
We also tried removing wikidata-dependent templates from 加冷河, which we suspected to be the cause. The tool still failed.

The corresponding wikidata item is https://www.wikidata.org/wiki/Q1094417 . To link the page you may use the following among others.
enwiki - Kallang River
dewiki - ditto
mswiki - Sungai Kallang
zhwiki - 加冷河

Event Timeline

Roy17 created this task.Oct 26 2018, 1:58 PM
Restricted Application added subscribers: Cosine02, Aklapper. · View Herald TranscriptOct 26 2018, 1:58 PM
Roy17 renamed this task from Sidebar interwiki linking failed to [BUG] Sidebar interwiki linking failed.Oct 26 2018, 3:11 PM
Roy17 removed a subscriber: Roy17.
jeblad added a subscriber: jeblad.Oct 26 2018, 7:23 PM

Probably the same as T208077, there are more information in that report.

Change 470139 had a related patch set uploaded (by Addshore; owner: Addshore):
[operations/mediawiki-config@master] Wikibase, Set siteLinkGroups settings on all wikis again

https://gerrit.wikimedia.org/r/470139

Change 470139 merged by jenkins-bot:
[operations/mediawiki-config@master] Wikibase, Set siteLinkGroups settings on all wikis again

https://gerrit.wikimedia.org/r/470139

Mentioned in SAL (#wikimedia-operations) [2018-10-27T08:34:52Z] <addshore@deploy1001> Synchronized wmf-config/Wikibase.php: Wikibase, Set siteLinkGroups settings on all wikis again T208048 T208077 T208074 (duration: 00m 54s)

Restricted Application added a project: User-Addshore. · View Herald TranscriptOct 27 2018, 8:36 AM
Roy17 reopened this task as Open.Oct 27 2018, 2:30 PM

Where are we following this bug now? All T208048 T208074 T208077 have been closed as duplicates of one another, but the problem in T208048 still exists. Still not possible to connect https://zh-yue.wikipedia.org/wiki/加冷河 with the sidebar tool.

At 2018-10-27 13:24 UTC there was another report of this persistent problem, see https://zh-yue.wikipedia.org/wiki/Wikipedia:城市論壇_(技術)#linkitem好似有bug .

Where are we following this bug now? All T208048 T208074 T208077 have been closed as duplicates of one another, but the problem in T208048 still exists. Still not possible to connect https://zh-yue.wikipedia.org/wiki/加冷河 with the sidebar tool.
At 2018-10-27 13:24 UTC there was another report of this persistent problem, see https://zh-yue.wikipedia.org/wiki/Wikipedia:城市論壇_(技術)#linkitem好似有bug .

Yup, the first fix didn't work, I have merged this task into the other task that is an exact duplicate of this (and open currently)