Page MenuHomePhabricator

Wikibase Lexeme emits "PHP Warning: Class __PHP_Incomplete_Class has no unserializer"
Closed, ResolvedPublicPRODUCTION ERROR

Description

Error

Request ID: W9OUpwpAADwAAFzosmYAAABM

message
PHP Warning: Class __PHP_Incomplete_Class has no unserializer
trace
#0 /srv/mediawiki/php-1.33.0-wmf.1/includes/objectcache/SqlBagOStuff.php(697): MWExceptionHandler::handleError(integer, string, string, integer, array, array)
#1 /srv/mediawiki/php-1.33.0-wmf.1/includes/objectcache/SqlBagOStuff.php(299): SqlBagOStuff->unserialize(string)
#2 /srv/mediawiki/php-1.33.0-wmf.1/includes/objectcache/SqlBagOStuff.php(242): SqlBagOStuff->getMulti(array)
#3 /srv/mediawiki/php-1.33.0-wmf.1/includes/objectcache/SqlBagOStuff.php(238): SqlBagOStuff->getWithToken(string, NULL, integer)
#4 /srv/mediawiki/php-1.33.0-wmf.1/includes/libs/objectcache/BagOStuff.php(197): SqlBagOStuff->doGet(string, integer)
#5 /srv/mediawiki/php-1.33.0-wmf.1/includes/libs/objectcache/MultiWriteBagOStuff.php(114): BagOStuff->get(string, integer)
#6 /srv/mediawiki/php-1.33.0-wmf.1/includes/libs/objectcache/BagOStuff.php(197): MultiWriteBagOStuff->doGet(string, integer)
#7 /srv/mediawiki/php-1.33.0-wmf.1/includes/parser/ParserCache.php(247): BagOStuff->get(string, integer, integer)
#8 /srv/mediawiki/php-1.33.0-wmf.1/includes/page/Article.php(689): ParserCache->get(WikiPage, ParserOptions)
#9 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Wikibase/repo/includes/Actions/ViewEntityAction.php(79): Article->view()
#10 /srv/mediawiki/php-1.33.0-wmf.1/extensions/Wikibase/repo/includes/Actions/ViewEntityAction.php(54): Wikibase\ViewEntityAction->showEntityPage()
#11 /srv/mediawiki/php-1.33.0-wmf.1/extensions/WikibaseLexeme/src/MediaWiki/Actions/ViewLexemeAction.php(16): Wikibase\ViewEntityAction->show()
#12 /srv/mediawiki/php-1.33.0-wmf.1/includes/MediaWiki.php(501): Wikibase\Lexeme\MediaWiki\Actions\ViewLexemeAction->show()
#13 /srv/mediawiki/php-1.33.0-wmf.1/includes/MediaWiki.php(294): MediaWiki->performAction(Article, Title)
#14 /srv/mediawiki/php-1.33.0-wmf.1/includes/MediaWiki.php(860): MediaWiki->performRequest()
#15 /srv/mediawiki/php-1.33.0-wmf.1/includes/MediaWiki.php(517): MediaWiki->main()

Impact

Unknown.

Notes

Regression since this week's branch. Example request: GET /wiki/Lexeme:L2747

Event Timeline

Krinkle created this task.Oct 26 2018, 10:30 PM
Restricted Application added a project: Wikidata. · View Herald TranscriptOct 26 2018, 10:30 PM

It might be it is not related to the code change, but to changes to config of WMF wikis that @Addshore and me have been doing around the time this bug has been reported.
Errors looks similar too symptoms we've been struggling with in T195615, which makes me suspicious that config might be related here.

AFAIK config should be now OK. Could you verify that errors ceased to appear?

mmodell closed this task as Resolved.Oct 30 2018, 10:23 PM
mmodell claimed this task.
mmodell added a subscriber: mmodell.

I only see one instance of this in all of logstash's history. I think it is safe to assume that it was transient. Alternatively, this is likely dupe of T195615

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:08 PM