Page MenuHomePhabricator

Allow to delete recording on-the-fly
Closed, ResolvedPublic

Description

Hello,
would it be possible to allow to delete some recordings during the recording step (when we read words one by one). It could be done using the "Del" key of the keyboard (arrow keys are already used to pass to the next/previous word of the list).
I need such possibility because when I record a large number of words from a list, sometimes I do not know how to pronounce a word. Usually I skip it using the arrow key of the keyboard (or a click on the next word), but sometimes something is recording (for example noisy sound or a try to pronounce the word before I think I do not know how to pronounce it, ...).

When it happens, the only way not to upload this word on Commons is to remember this word and to remove it during the enxt step (upload step). Yet, when we record a large number of words, it could be quite difficult to remember which words have to be deleted. Allowing to remove pronunciation during the recording step in order not to upload them would be really useful.

Event Timeline

Pamputt created this task.Oct 28 2018, 1:49 PM

Just to be clear, what you want is to delete the audio record attached to an item, but not the item itself, am I right?

If yes, this is pretty simple to do, my only concerns are about the UX part. Having just a keyboard shortcut without anything in the UI which indicates the existence of this feature seems odd to me. Do you have an idea how this can be done?

In order to be clear, I attach this picture. Here I recorded "bahá’í" and "sabaot" (circled in red) but I do not know how to pronounce them. So I would like to make them "blue" again (like "afrikaans" that I skipped) and "green" like the others that are validated words. I guess at this stage the items are not yet created. So what I would like is to be able to "devalidate" these words (and so not to do it at the upload stage).

0x010C closed this task as Resolved.Oct 28 2018, 9:53 PM

Done in commit a0e71c4. Pressing the [del] key will reset the currently highlighted item.

But the issue is now about how to let users know that this keyboard shortcut exists... I'll open a separate ticket for that.