Page MenuHomePhabricator

File Captions help/error text
Closed, ResolvedPublic

Description

I did a dry run of the file caption usability study on Friday, and unfortunately, the usability tester ran into an error saving the caption, which prevents me from releasing the usability study to the remaining participants.

However, there is some feedback from the test which is valuable for us, regardless of whether we are able to fix what's resulting in the error that prevents the system from saving captions, which I am detailing below.

Help text in the caption field: "No caption defined" is unclear. It didn't give enough of a clue that a caption should be entered into the field.
Suggested change: use this text: "Add a one-line explanation of what this file represents" (which is a shortened version of the entire UW text: "Add a one-line explanation of what this file represents, including only the most relevant information")

Save error text is unhelpful. "The file has failed" error message is unclear and inconsistent. The tester was unable to publish captions despite many efforts, and for most of the time testing, blamed herself and her keyboard settings because the error messaging was vague and didn't indicate it was a system error. If two captions are being added at once, only one field will display an error, not both. This inconsistency was very confusing to the tester.
What else can we use that's accurate but also gives more information to the user so they know it's not their fault, but the system's?

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.

Event Timeline

Restricted Application added a project: Multimedia. · View Herald TranscriptOct 29 2018, 7:46 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Ramsey-WMF edited subscribers, added: Jdforrester-WMF; removed: Aklapper.Oct 30 2018, 4:40 AM

@Jdforrester-WMF assistance here would be fantastic :)

Change 470635 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/WikibaseMediaInfo@master] i18n: Reword wikibasemediainfo-filepage-caption-empty into a call to action

https://gerrit.wikimedia.org/r/470635

Re-wording "No caption defined" (wikibasemediainfo-filepage-caption-empty) is done in https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/WikibaseMediaInfo/+/470635

For "The save has failed", that's wikibase-api-failed-save which is part of Wikibase itself. It isn't very useful, because it's a generic error with lots of potential causes. I'm not sure why we're not getting wikibase-error-save-generic instead though, which would say "Could not save due to an error." which is… better, if not great.

@Jdforrester-WMF Thanks, James! I agree that "Could not save due to an error" is a better alternative... I don't think @Cparle was able to reproduce the error this usability tester had (it's an error I've experienced too), alas.

Ramsey-WMF triaged this task as Normal priority.Nov 2 2018, 5:24 PM
Ramsey-WMF moved this task from To Do to Doing on the Multimedia-Team-Working-Board board.
Ramsey-WMF moved this task from Untriaged to Needs Design on the Multimedia board.Nov 2 2018, 5:31 PM

I'm doing the first bit, at least.

Change 470635 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] i18n: Reword wikibasemediainfo-filepage-caption-empty into a call to action

https://gerrit.wikimedia.org/r/470635

Ramsey-WMF closed this task as Resolved.Dec 3 2018, 5:36 PM