Page MenuHomePhabricator

Blocks log entries display as malformed on Special:CheckUser
Closed, ResolvedPublic2 Estimated Story Points

Description

When viewing the 'Get edits' for an IP address that includes a user or IP that has been partially blocked, the block expiration of the log entry appears malformed:

TBolliger (WMF) blocked Oct-31-test-2 from editing Cow with an expiration time of <span class="blockExpiry" title="‎1 year">1 year</span> (autoblock disabled)


Expected behavior

  • The block log entries should not show rogue HTML span tags

Event Timeline

Restricted Application added subscribers: MGChecker, Aklapper. · View Herald TranscriptNov 1 2018, 5:13 PM
Kbrown added a subscriber: Kbrown.Nov 1 2018, 10:44 PM
TBolliger set the point value for this task to 2.Nov 29 2018, 7:26 PM

This also affects sitewide blocks in the same way.

It's due to HTML escaping in SpecialCheckUser::CUChangesLine():

$line .= ' ' . Linker::formatComment( $row->cuc_actiontext ) . ' ';
dmaza claimed this task.Dec 14 2018, 3:22 AM
dmaza edited projects, added Anti-Harassment (AHT Sprint 35); removed Anti-Harassment.
dmaza moved this task from Ready to In progress on the Anti-Harassment (AHT Sprint 35) board.

Change 481204 had a related patch set uploaded (by Dmaza; owner: Dmaza):
[mediawiki/core@master] Make Linker::formatAutocomments public

https://gerrit.wikimedia.org/r/481204

Change 481205 had a related patch set uploaded (by Dmaza; owner: Dmaza):
[mediawiki/extensions/CheckUser@master] Fix raw html output on logs

https://gerrit.wikimedia.org/r/481205

dmaza renamed this task from Partial blocks log entries display as malformed on Special:CheckUser to Blocks log entries display as malformed on Special:CheckUser.Dec 21 2018, 8:59 PM
dmaza moved this task from In progress to Review on the Anti-Harassment (AHT Sprint 35) board.

Change 482606 had a related patch set uploaded (by Thiemo Kreuz (WMDE); owner: Thiemo Kreuz (WMDE)):
[mediawiki/core@master] Extract summary (comment) formatting from Linker to SummaryFormatter

https://gerrit.wikimedia.org/r/482606

Change 483169 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[mediawiki/core@master] Fix malformed output of block logs

https://gerrit.wikimedia.org/r/483169

Change 481205 abandoned by Tchanders:
Fix raw html output on logs

Reason:
Following Catrope's advice here: Id3fcdfda7311484911ae1f57ec262a2c6e6ab00b

https://gerrit.wikimedia.org/r/481205

Change 483169 merged by jenkins-bot:
[mediawiki/core@master] Fix malformed output of block logs

https://gerrit.wikimedia.org/r/483169

Change 481204 abandoned by Mooeypoo:
Make Linker::formatAutocomments public

Reason:
No longer necessary due to Id3fcdfda731

https://gerrit.wikimedia.org/r/481204

dbarratt closed this task as Resolved.Jan 9 2019, 9:13 PM
dbarratt reassigned this task from dmaza to Tchanders.
dbarratt moved this task from Review to Done on the Anti-Harassment (Alef — א) board.
dbarratt added a subscriber: dmaza.

Change 482606 abandoned by Thiemo Kreuz (WMDE):
[mediawiki/core@master] Extract comment (summary) formatting from Linker to CommentFormatter

Reason:
Not worth my time doing politics for smaller code quality improvements like this while everybody is busy deprecating everything the same time just to prove a point.

https://gerrit.wikimedia.org/r/482606