Page MenuHomePhabricator

date parameter issue (InternetArchiveBot) on kowiki
Closed, ResolvedPublic

Description

A new bug report has been recently issued by User:메이 from https://ko.wikipedia.org/w/index.php?title=위키백과:사랑방_(기술)/2018년_11월
that the User:InternetArchiveBot's contributions still produce the invalid date format such as YYYY년 MM월 DD일 which should be simply replaced with YYYY-MM-DD.

For example, 보존날짜=2013년 07월 02일 needs to be replaced with either

보존날짜=2013-07-02    (YYYY-MM-DD ISO-8601 standard)
      or
보존날짜=2013년 7월 2일 (From Jan through Sep, we don't add pad 0 to the left of the months. It applies to the days as well; this is comparable to the English context that July 2, 2013 is valid, not July 02, 2013.)

For details, please refer to the following diffs:
https://ko.wikipedia.org/w/index.php?diff=22907169
https://ko.wikipedia.org/w/index.php?diff=22911557
https://ko.wikipedia.org/w/index.php?diff=22912247

According to the last bug report, the date issue has been confirmed to be fixed by Cyberpower678, but the problem still seems to persist.
https://ko.wikipedia.org/wiki/%EC%9C%84%ED%82%A4%EB%B0%B1%EA%B3%BC:%EC%82%AC%EB%9E%91%EB%B0%A9_(%EA%B8%B0%EC%88%A0)/2018%EB%85%84_9%EC%9B%94#InternetArchiveBot%EC%9D%98_%EC%9E%91%EB%8F%99%EC%97%90_%EB%94%B0%EB%A5%B4%EB%8A%94_%EB%82%A0%EC%A7%9C_%EC%98%A4%EB%A5%98%EC%9D%98_%EB%B0%9C%EC%83%9D%EC%97%90_%EB%8C%80%ED%95%B4%EC%84%9C

Event Timeline

Ykhwong created this task.Nov 3 2018, 12:36 AM
Restricted Application added a subscriber: revi. · View Herald TranscriptNov 3 2018, 12:36 AM
Ykhwong updated the task description. (Show Details)Nov 3 2018, 12:37 AM
Ykhwong updated the task description. (Show Details)Nov 3 2018, 12:40 AM
Cyberpower678 closed this task as Resolved.Nov 7 2018, 8:07 PM

Sorry about that. I though the numbers where padded when I fixed the issue last time. They should be single digits now.

Thanks for the fix. Let me run your bot, check whether the issue is resolved and get back to you shortly.