Page MenuHomePhabricator

Groups being removed
Closed, ResolvedPublic

Description

Groups are being removed from civi records -

examples:
543067
1975252

I removed some tags on these records and then noticed that they were removed from all their groups. The change log indicated that I removed them but I DIDN'T (promise)

Event Timeline

NNichols created this task.Nov 5 2018, 11:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 5 2018, 11:12 PM
Restricted Application added subscribers: Pcoombe, Liuxinyu970226, TerraCodes. · View Herald TranscriptNov 5 2018, 11:18 PM

@Ejegg so it turns out that when we tested this we were interested in groups AND tags so I think we maybe both tested profiles with both on them & that is fine. The problem is groups OR tags

I've submitted a fix for this & am discussing upstream

https://github.com/civicrm/org.civicrm.contactlayout/issues/40

There appear to be only 24 contacts involved so it may make sense for you to just go through them @NNichols - although the bottom 5 were not your changes.

It might pay to wait until the fix is deployed though & then I'll re-run the query to confirm no more emerged

select group_id, contact_id, status, log_date FROM log_civicrm_group_contact WHERE status = 'Removed' AND log_date > '2018-06-01' GROUP BY contact_id ORDER BY log_user_id DESC LIMIT 100;
+----------+------------+---------+---------------------+

group_idcontact_idstatuslog_date

+----------+------------+---------+---------------------+

2012825385Removed2018-06-05 17:20:15
30810483393Removed2018-10-12 01:09:13
1896047Removed2018-10-02 21:37:43
33718248290Removed2018-09-26 03:57:43
279543067Removed2018-11-05 21:43:03
48320606028Removed2018-10-16 13:57:19
2761945778Removed2018-10-03 18:56:14
2761079949Removed2018-09-27 03:46:20
44614805241Removed2018-08-21 18:15:49
2918711748Removed2018-10-16 14:03:09
4794599899Removed2018-10-03 18:58:15
44619951402Removed2018-08-21 18:16:19
187649568Removed2018-10-22 16:56:43
33724133817Removed2018-10-09 16:28:54
2765923619Removed2018-10-02 18:17:50
446168381Removed2018-08-21 18:16:39
2761975252Removed2018-10-24 19:49:27
32426157257Removed2018-10-10 19:00:46
276499654Removed2018-10-02 18:18:12
472749315Removed2018-09-11 22:46:39
3385353397Removed2018-07-02 21:29:32
187388009Removed2018-11-05 23:14:22
187250422Removed2018-10-01 16:46:57
32426158203Removed2018-11-03 18:26:35

+----------+------------+---------+---------------------+

ok - @NNichols just deployed the no-more fix & the above table is the whole list

Thanks Eileen! Glad the list was small enough to review in one sitting.

@NNichols this has been working OK since the fix? Good to close?

I think we're good. I haven't seen it happen again.

Eileenmcnaughton closed this task as Resolved.Nov 15 2018, 2:33 AM