rename tegmen to icinga2001 and reinstall it with stretch
Closed, ResolvedPublic

Dzahn created this task.Nov 6 2018, 1:39 AM
Dzahn triaged this task as High priority.

Change 471896 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/dns@master] rename tegmen.mgmt to icinga2001.mgmt

https://gerrit.wikimedia.org/r/471896

Change 471897 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/dns@master] rename tegmen.wikimedia.org to icinga2001.wikimedia.org

https://gerrit.wikimedia.org/r/471897

Change 471898 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] rename tegmen to icinga2001 in puppet, DHCP, and use stretch

https://gerrit.wikimedia.org/r/471898

Change 471899 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] smokeping: replace tegmen with icinga2001 target

https://gerrit.wikimedia.org/r/471899

Change 471900 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] mailman: whitelist icinga1001 IP alongside einsteinium and tegmen

https://gerrit.wikimedia.org/r/471900

Change 471900 merged by Dzahn:
[operations/puppet@production] mailman: whitelist icinga1001 IP alongside einsteinium and tegmen

https://gerrit.wikimedia.org/r/471900

Change 471896 merged by Dzahn:
[operations/dns@master] rename tegmen.mgmt to icinga2001.mgmt

https://gerrit.wikimedia.org/r/471896

Mentioned in SAL (#wikimedia-operations) [2018-11-07T00:46:55Z] <mutante> tegmen - shutting down for renaming and reinstall (T208824)

Dzahn added a comment.Nov 7 2018, 3:50 PM

@Volans Yea, i saw that and already sat tegmen to state INVENTORY in netbox. But what about the open questions that are also on that page, like what about the production DNS entries (as opposed to mgmt) and am i really supposed to have 2 DNS entries pointing to the same mgmt IP during reinstall? Wouldn't it be easier to just follow the old method of shutting it down, renaming it and installing it like a new one?

Volans added a comment.Nov 7 2018, 3:52 PM

Shutting down doesn't remove it from puppetdb, revoke it's puppet certificate and remove it from debmonitor though.

Volans added a comment.Nov 7 2018, 3:53 PM

[Sorry hit submit too early...]
So either shutdown and run the decom script and then reimage with --new or follow the steps that Luca has outlined there the last time he did it.

Change 472212 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/dns@master] keep tegmen.mgmt next to icinga2001.mgmt for renaming process using script

https://gerrit.wikimedia.org/r/472212

Change 472212 merged by Dzahn:
[operations/dns@master] keep tegmen.mgmt next to icinga2001.mgmt for renaming process using script

https://gerrit.wikimedia.org/r/472212

Change 472225 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/dns@master] renamed tegmen.wikimedia.org to icinga2001.wikimedia.org

https://gerrit.wikimedia.org/r/472225

Change 471897 abandoned by Dzahn:
rename tegmen.wikimedia.org to icinga2001.wikimedia.org

Reason:
duplicate of https://gerrit.wikimedia.org/r/#/c/operations/dns/ /472225/

https://gerrit.wikimedia.org/r/471897

Change 471898 merged by Cwhite:
[operations/puppet@production] rename tegmen to icinga2001 in puppet, DHCP, and use stretch

https://gerrit.wikimedia.org/r/471898

Change 472225 merged by Cwhite:
[operations/dns@master] rename tegmen.wikimedia.org to icinga2001.wikimedia.org

https://gerrit.wikimedia.org/r/472225

Change 471899 merged by Cwhite:
[operations/puppet@production] smokeping: replace tegmen with icinga2001 target

https://gerrit.wikimedia.org/r/471899

Script wmf-auto-reimage was launched by cwhite on cumin1001.eqiad.wmnet for hosts:

tegmen.mgmt.codfw.wmnet

The log can be found in /var/log/wmf-auto-reimage/201811142042_cwhite_90643_tegmen_mgmt_codfw_wmnet.log.

Completed auto-reimage of hosts:

['tegmen.mgmt.codfw.wmnet']

Of which those FAILED:

['tegmen.mgmt.codfw.wmnet']

Script wmf-auto-reimage was launched by cwhite on cumin1001.eqiad.wmnet for hosts:

tegmen.wikimedia.org

The log can be found in /var/log/wmf-auto-reimage/201811142043_cwhite_90897_tegmen_wikimedia_org.log.

Completed auto-reimage of hosts:

['icinga2001.wikimedia.org']

Of which those FAILED:

['icinga2001.wikimedia.org']

Script wmf-auto-reimage was launched by cwhite on cumin1001.eqiad.wmnet for hosts:

tegmen.wikimedia.org

The log can be found in /var/log/wmf-auto-reimage/201811142058_cwhite_94473_tegmen_wikimedia_org.log.

Completed auto-reimage of hosts:

['tegmen.wikimedia.org']

Of which those FAILED:

['tegmen.wikimedia.org']

Script wmf-auto-reimage was launched by cwhite on cumin1001.eqiad.wmnet for hosts:

tegmen.wikimedia.org

The log can be found in /var/log/wmf-auto-reimage/201811142105_cwhite_97557_tegmen_wikimedia_org.log.

Completed auto-reimage of hosts:

['tegmen.wikimedia.org']

Of which those FAILED:

['tegmen.wikimedia.org']

Script wmf-auto-reimage was launched by cwhite on cumin1001.eqiad.wmnet for hosts:

tegmen.wikimedia.org

The log can be found in /var/log/wmf-auto-reimage/201811142108_cwhite_98622_tegmen_wikimedia_org.log.

Completed auto-reimage of hosts:

['icinga2001.wikimedia.org']

Of which those FAILED:

['icinga2001.wikimedia.org']

Change 473642 had a related patch set uploaded (by Cwhite; owner: Cwhite):
[operations/puppet@production] icinga: copy stretch options to icinga2001

https://gerrit.wikimedia.org/r/473642

Change 473642 merged by Cwhite:
[operations/puppet@production] icinga: copy stretch options to icinga2001

https://gerrit.wikimedia.org/r/473642

Change 473789 had a related patch set uploaded (by Cwhite; owner: Cwhite):
[operations/puppet@production] icinga: manage permissions for replicated files

https://gerrit.wikimedia.org/r/473789

Change 473820 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/dns@master] remove tegmen.mgmt which was duplicated for renaming

https://gerrit.wikimedia.org/r/473820

Change 473820 merged by Dzahn:
[operations/dns@master] remove tegmen.mgmt which was duplicated for renaming

https://gerrit.wikimedia.org/r/473820

Dzahn closed this task as Resolved.Nov 15 2018, 9:13 PM

Change 473789 merged by Cwhite:
[operations/puppet@production] icinga: manage permissions for replicated files

https://gerrit.wikimedia.org/r/473789

edited https://netbox.wikimedia.org/dcim/devices/1705/ and renamed in Netbox and set to status "Active" instead of "Inventory".

Mentioned in SAL (#wikimedia-operations) [2018-11-26T18:46:54Z] <mutante> removed allowed sender addresses from AQL (mail2SMS gateway) portal: @einsteinium @tegmen addresses T208824 T209738