Page MenuHomePhabricator

There should be a difference between section header and bold text in preferences
Closed, ResolvedPublic

Description

Steps to reproduce

  1. Go to Special:Preferences on desktop
  2. Try to navigate yourself in the page

Expected behavior
It should be clear, where a section starts and ends, to easily navigate the section you look for. In previous UI there was a horizontal line breaking page to sections and also some space between sections. There is no need to add horizontal lines or more space around, one of the possible solutions can also be a indentation of section content

Current behavior
There is no clear break between sections and therefore longer preferences tabs seems just like one long cluttered section, one seamless long buch of text. Not sure if it is a new section or just bold text. Unfortunately there is no way to easily find the desired section now.

Configuration
Firefox 63

Event Timeline

Dvorapa created this task.Nov 6 2018, 9:24 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 6 2018, 9:24 AM
Dvorapa updated the task description. (Show Details)Nov 6 2018, 9:26 AM
Dvorapa updated the task description. (Show Details)Nov 6 2018, 12:18 PM
Volker_E updated the task description. (Show Details)Nov 15 2018, 6:23 AM

I honestly have a hard time following the argumentation here. Sure, there have been light grey horizontal lines, but with each section starting with a bigger font size, boldened and with minimum 1.5 times margin like between paragraphs, one could also argue the same about majority of websites out there where a smaller headline signifies a new section.

There is a minor issue though on closer inspection, that the font size wasn't at the aimed for 16px as intended, due to a generic element CSS rule that inherited all the way down into the OOUI structure of Special:Preferences.

There is a minor issue though on closer inspection, that the font size wasn't at the aimed for 16px as intended, due to a generic element CSS rule that inherited all the way down into the OOUI structure of Special:Preferences.

rMWe71c3439318e: Reset legend `font-size` in OOUI HTMLForms

I wonder if this would be enough to resolve this task?

Volker_E closed this task as Resolved.Nov 20 2018, 6:33 AM
Volker_E claimed this task.
Volker_E added a subscriber: Akhilam513.

@matmarex That was the identified issue I've pointed out in my comment above. I'll be bold and set this on resolved with the patch merged until further arguments are raised.

Hopefully it would do, I would only like to suggest to unbold the only bold text, that is not a heading or a button: "Don't use images, external links and templates." in the signature description.

@Dvorapa That's similar to T194533 – it's a description provided by enwiki community. Your request would need to be raised there. Compare dewiki treatment:

I'm speking about cswiki. Per your response it seems it can be fixed somewhere in the MediaWiki namespace??

Wow, I didn't know about qqx feature, this is what I missed all the years!