Page MenuHomePhabricator

Rewrite Ruby browser tests as Javascsript browser tests
Closed, DuplicatePublic

Description

Motivation
We want to stop maintaining two separate stacks for browser tests.
We have javascript written more recently.

Approach

  • we will disable ruby tests that are making the daily tests run against beta and test fail.
  • we start rewriting ruby browser tests one by one (in sub-tasks), keeping in mind that some of these tests might be not needed and can be discarded completely. That's to be figured out on each case separately while working on them.

[relevant info on current ruby tests]

This job used to be green in the early 2018, now seems to be failing again since couple of weeks, e.g. https://integration.wikimedia.org/ci/view/Selenium/job/selenium-Wikibase-chrome/BROWSER=chrome,MEDIAWIKI_ENVIRONMENT=beta,PLATFORM=Linux,label=DebianJessie%20&&%20contintLabsSlave/lastBuild/testReport/

There seems to be several types of failures of individual tests:

  • timed out after 15 seconds, Element was not visible in 15 seconds (Watir::Wait::TimeoutError) -> to check if it is a hiccups, or indicating some DOM change leading to not finding an element?
  • You do not have the permissions needed to carry out this action. (permissiondenied) (MediawikiApi::ApiError) -> is it some edit ratio limit maybe?
  • possibly more types of errors?

Event Timeline

WMDE-leszek triaged this task as Normal priority.Nov 6 2018, 1:53 PM
WMDE-leszek created this task.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 6 2018, 1:53 PM
Addshore moved this task from incoming to ready to go on the Wikidata board.Nov 7 2018, 9:46 AM
This comment was removed by Addshore.
alaa_wmde updated the task description. (Show Details)Apr 23 2019, 9:06 AM
alaa_wmde closed this task as Invalid.Apr 23 2019, 9:11 AM

Duplicate of T180228

thanks @Michael I thought I saw that one sometime ago 👍