[testwiki wmf3-regression] Watchlist: Misaligned dotdotdot in 'Saved filters'
Closed, ResolvedPublic

Description

The issue is present in testwiki and betalabs.

  1. On testwiki go to Watchlist (or RecentChanges) with enabled filters.
  2. Click on Saved filters - the dotdotdot will be misalgned:

It could be corrected with (per @Volker_E investigation):

Another manifestation of misalignment:

vs

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 6 2018, 9:08 PM
Volker_E claimed this task.Nov 6 2018, 9:11 PM
Volker_E triaged this task as High priority.
Etonkovidova updated the task description. (Show Details)Nov 6 2018, 9:19 PM

The third place to check after the fix: Special:Notifications:

Change 472072 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/core@master] Revert "RCFilters: Use display: flex for better responsiveness on narrow canvas"

https://gerrit.wikimedia.org/r/472072

Change 472072 merged by jenkins-bot:
[mediawiki/core@master] Revert "RCFilters: Use display: flex for better responsiveness on narrow canvas"

https://gerrit.wikimedia.org/r/472072

Change 472083 had a related patch set uploaded (by Jforrester; owner: VolkerE):
[mediawiki/core@wmf/1.33.0-wmf.3] Revert "RCFilters: Use display: flex for better responsiveness on narrow canvas"

https://gerrit.wikimedia.org/r/472083

The reported issue is fixed in betalabs.

There are two more places where stuff is misaligned - the notification flyout and Special:Notifications - or it's a different issue?

Aklapper renamed this task from [testwiki wmf3-regression] Watchlist: Misalgned dotdotdot in 'Saved filters' to [testwiki wmf3-regression] Watchlist: Misaligned dotdotdot in 'Saved filters' .Nov 7 2018, 3:56 AM
Restricted Application added a project: Growth-Team. · View Herald TranscriptNov 7 2018, 3:56 AM

The reported issue is fixed in betalabs.

There are two more places where stuff is misaligned - the notification flyout and Special:Notifications - or it's a different issue?

That's T208930.

That's being worked on by @Volker_E right now.

Volker_E added a comment.EditedNov 7 2018, 3:58 AM

@Etonkovidova Thanks, truly helpful. Those are from a different task, T208930

Change 472083 merged by jenkins-bot:
[mediawiki/core@wmf/1.33.0-wmf.3] Revert "RCFilters: Use display: flex for better responsiveness on narrow canvas"

https://gerrit.wikimedia.org/r/472083

Mentioned in SAL (#wikimedia-operations) [2018-11-07T16:33:05Z] <jforrester@deploy1001> Synchronized php-1.33.0-wmf.3/resources/src/mediawiki.rcfilters/styles/mw.rcfilters.ui.less: T208898 Hot-deploy to wmf.3 (duration: 00m 53s)

Now live in production on wmf.3.

Etonkovidova closed this task as Resolved.Nov 7 2018, 8:00 PM

Checked in testwiki wmf.3 - all seems to be correctly in place.