Rollout SVGs in page language
Closed, ResolvedPublic3 Story Points

Description

SVGs in page language are live on the beta cluster and seem to work well so far. This ticket is to roll it out on all wikis. Here's the proposed break-out for rollout to happen:

  • Testwiki
  • group 0
  • group1
  • group2

I don't mind if the order changes as long as it goes live everywhere.


Things to monitor:

Niharika created this task.Nov 6 2018, 9:10 PM
Niharika triaged this task as Normal priority.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 6 2018, 9:10 PM
aezell added a subscriber: aezell.Nov 7 2018, 12:10 AM

Max thinks the page save latency graph might be the best measure here.

Niharika set the point value for this task to 3.Nov 7 2018, 12:10 AM
Niharika added a subscriber: MaxSem.

Need to put this in the sprint as I initially expected this to be done as part of T205040: Show SVGs in page language if available and now we're behind schedule.

@MaxSem Can you put dates on this to give me an estimate of when I can expect this done? Testwiki this week and rest next week maybe?

MaxSem claimed this task.Nov 7 2018, 3:01 AM
MaxSem added a comment.Nov 7 2018, 3:07 AM

We have a clear development policy that says that features must be hidden behind feature flags and technical analysis of the proposal clearly indicated that such a flag would be needed as there are fears of performance regression. In such situations, things never just appear in production without a plan. Besides, was "deploy it to production" part of acceptance criteria?

Change 472091 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[operations/mediawiki-config@master] Enable wgMediaInTargetLanguage on testwiki

https://gerrit.wikimedia.org/r/472091

We have a clear development policy that says that features must be hidden behind feature flags and technical analysis of the proposal clearly indicated that such a flag would be needed as there are fears of performance regression. In such situations, things never just appear in production without a plan. Besides, was "deploy it to production" part of acceptance criteria?

Well, you wrote that ticket. It didn't explicitly say anything and I assumed that deployment would be a part of that ticket. We don't always have separate tickets for deployments. Nevertheless, my question about deployment dates still stands. I'm responsible for communicating with the community about this feature and doing the QA work on it so it would be helpful to me to know when you plan to put this out.

Testwiki today, the rest will be determined when we have clarity regarding performance monitoring.

Change 472091 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable wgMediaInTargetLanguage on testwiki

https://gerrit.wikimedia.org/r/472091

Mentioned in SAL (#wikimedia-operations) [2018-11-08T00:12:27Z] <jforrester@deploy1001> Synchronized wmf-config/InitialiseSettings.php: T208899 Enabling wgMediaInTargetLanguage for testwiki (duration: 00m 54s)

MaxSem updated the task description. (Show Details)Sat, Nov 10, 5:06 AM
MaxSem updated the task description. (Show Details)

@MaxSem Following up on your last comment - do we have any more clarity on the performance monitoring now? I'd like to do a wider rollout when we can.

Yes, we can do it next week or whenever you're ready.

@MaxSem Let's do it next week. Question for you - is the performance impact affected by how many SVGs are put on wikis without the lang flag or it is impacted by all images lang flag notwithstanding?

If everything goes well, there will be no performance hit. I don't understand the part about lang - this feature is about not needing it.

@MaxSem Right. I am assuming that the production impact will theoretically be caused by the computation which decides which language to generate the image in. If that assumption is correct, do images which are added with an explicit lang flag not cause a performance impact? Or it is caused for all images irrespective of the presence of the lang flag? If that assumption is incorrect, what part of the process is expected to cause a performance impact?
I hope my question is clear.

Change 475005 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[operations/mediawiki-config@master] Enable SVGs in page in group1, rest of group0

https://gerrit.wikimedia.org/r/475005

Change 475005 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable SVGs in page in group1, rest of group0

https://gerrit.wikimedia.org/r/475005

Niharika updated the task description. (Show Details)Wed, Nov 21, 1:38 AM

@MaxSem When do you plan to deploy this to Group2?

I see no changes in graphs, ready when you are.

I see no changes in graphs, ready when you are.

Let's swat it today evening.

Change 475919 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[operations/mediawiki-config@master] Enable SVGs in page language everywhere

https://gerrit.wikimedia.org/r/475919

Change 475919 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable SVGs in page language everywhere

https://gerrit.wikimedia.org/r/475919

Mentioned in SAL (#wikimedia-operations) [2018-11-27T00:27:42Z] <niharika29@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Enable SVGs in page language everywhere T208899 (duration: 00m 46s)

Mentioned in SAL (#wikimedia-operations) [2018-11-27T00:29:08Z] <niharika29@deploy1001> Synchronized wmf-config/InitialiseSettings-labs.php: Enable SVGs in page language everywhere T208899 (duration: 00m 45s)

Niharika updated the task description. (Show Details)Tue, Nov 27, 11:11 PM
Niharika closed this task as Resolved.Tue, Nov 27, 11:45 PM
Niharika moved this task from Product/QA review to Done on the Community-Tech-Sprint board.