Page MenuHomePhabricator

Partially blocked users should be able to review pending changes for other pages
Closed, ResolvedPublic

Description

Pending changes is a level of protection that allows unprivileged users to make edits which are saved but not displayed to readers until they are manually reviewed. It is used infrequently but still needs to cooperate with Partial Blocks.

The Beta environment has pending changes enabled — https://en.wikipedia.beta.wmflabs.org/wiki/Special:PendingChanges

You need three users to test this:

  1. Someone to make an edit to trigger pending changes. I used a logged-out IP.
  2. A user with reviewer permissions to review the changes who will be partially blocked. For my example I created User:Nov-6-18-test.
  3. An admin to block. For my example I used User:TBolliger.

Expected behavior

  • A partially blocked user with reviewer permissions...
    • 1. should not be able to review pending changes on pages defined in their partial block
    • 2. should be able to review pending changes on pages not within the parameters of their partial block

Use case 1 — success

If a user is PB'd from a page (in this case FR test they cannot review the pending changes:


Use case 2 — failure

If a user is not PB'd from a page, they are prohibited from reviewing all pages. Please fix this defect.

Event Timeline

Restricted Application added subscribers: MGChecker, Aklapper. · View Herald TranscriptNov 7 2018, 12:43 AM

It looks like RevisionReviewForm::isAllowed() looks like this:

public function isAllowed() {
  // Basic permission check
  return ( $this->page && $this->page->userCan( 'review' ) );
}

Which means the problem describe in this task should be when T208862 is resolved

It looks like RevisionReviewForm::isAllowed() looks like this:

public function isAllowed() {
  // Basic permission check
  return ( $this->page && $this->page->userCan( 'review' ) );
}

Which means the problem describe in this task should be when T208862 is resolved

Can we merge these tasks? I don't see a reason to have two tasks.

TBolliger renamed this task from Partially blocked users should be able to review pending for other pages to Partially blocked users should be able to review pending changes for other pages.Nov 7 2018, 5:44 PM

Can we merge these tasks? I don't see a reason to have two tasks.

Up to you. The only reason I would leave this one is for QA purposes (i.e. to ensure that after T208862 this ticket is fixed).

Catrope moved this task from Inbox to External on the Growth-Team board.Nov 27 2018, 7:21 AM
TBolliger changed the task status from Stalled to Open.Jan 30 2019, 10:56 PM
aezell updated the task description. (Show Details)Feb 7 2019, 6:17 PM

to re-test on beta

TBolliger closed this task as Resolved.Feb 11 2019, 10:35 PM

Tested again. The situation has been resolved!