Page MenuHomePhabricator

TitlesMultiSelectWidget sometimes styles as invalid when all tags are valid
Closed, ResolvedPublic

Description

On adding a tag from the input, the widget toggles invalid if there is text in the input, whether the tag was valid or invalid.

This is a regression since T208507 and comes from OO.ui.MenuTagMultiselectWidget clearing the input too late. (OO.ui.TagMultiselectWidget behaves correctly.)

Event Timeline

Tchanders created this task.Nov 7 2018, 5:43 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 7 2018, 5:43 PM

Change 472226 had a related patch set uploaded (by Tchanders; owner: Tchanders):
[oojs/ui@master] OO.ui.MenuTagMultiselectWidget: clear input if adding valid tag

https://gerrit.wikimedia.org/r/472226

Change 472226 merged by jenkins-bot:
[oojs/ui@master] MenuTagMultiselectWidget: clear input if adding valid tag

https://gerrit.wikimedia.org/r/472226

Change 472587 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/core@master] Update OOUI to v0.29.5

https://gerrit.wikimedia.org/r/472587

Change 472587 merged by jenkins-bot:
[mediawiki/core@master] Update OOUI to v0.29.5

https://gerrit.wikimedia.org/r/472587

Volker_E closed this task as Resolved.Nov 12 2018, 12:53 AM
Volker_E triaged this task as Normal priority.
Volker_E moved this task from Backlog to OOUI-0.29.5 on the OOUI board.
Volker_E edited projects, added OOUI (OOUI-0.29.5); removed OOUI.
Volker_E removed a project: Patch-For-Review.
Volker_E removed a subscriber: gerritbot.