Page MenuHomePhabricator

Flaky TwoColConflict test "The help dialog is visible" (mwselenium)
Closed, ResolvedPublic

Description

https://integration.wikimedia.org/ci/job/mwselenium-quibble-docker/3430/console
https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/TwoColConflict/+/472175/

    When The help dialog is visible                 # features/support/step_definitions/help_steps.rb:30
      timed out after 5 seconds, Element not present in 5 seconds (Watir::Wait::TimeoutError)
      features/help.feature:19:in `When The help dialog is visible'
    And I have moved to the next step               # features/support/step_definitions/help_steps.rb:18
    And I have moved to the next step               # features/support/step_definitions/help_steps.rb:18
    And I have moved to the next step               # features/support/step_definitions/help_steps.rb:18
    And I have moved to the next step               # features/support/step_definitions/help_steps.rb:18
    And I have closed the help dialog at the end    # features/support/step_definitions/help_steps.rb:14
    Then The help dialog should not be present      # features/support/step_definitions/help_steps.rb:38

Failing Scenarios:
cucumber features/autoscroll.feature:8 # Scenario: Basic two-column edit conflict page is shown correctly
cucumber features/base_selection.feature:8 # Scenario: The base selection dialog shows with the correct preselection
cucumber features/base_selection.feature:14 # Scenario: Using the currently published version in the selection dialog shows that version
cucumber features/base_selection.feature:25 # Scenario: Using my text in the selection dialog shows that version
cucumber features/edit_conflict.feature:8 # Scenario: Basic two-column edit conflict page is shown correctly
cucumber features/filter_options.feature:8 # Scenario: Hide common changes filter collapses common changes
cucumber features/filter_options.feature:16 # Scenario: Hide common changes when clicking a collapse changes button
cucumber features/filter_options.feature:26 # Scenario: Show hidden common changes when clicking an expand changes button
cucumber features/help.feature:9 # Scenario: Two column edit conflict tutorial is present on first load
cucumber features/help.feature:12 # Scenario: Two column edit conflict tutorial is not present after it was dismissed once
cucumber features/help.feature:18 # Scenario: Two column edit conflict sequence works

11 scenarios (11 failed)
112 steps (11 failed, 41 skipped, 60 passed)

Event Timeline

Krinkle created this task.Nov 7 2018, 8:29 PM
Restricted Application added a project: archived--TCB-Team. · View Herald TranscriptNov 7 2018, 8:29 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Is this a duplicate of T222441: TwoColConflict browser tests are flapping? Anyway, this got resolved with https://gerrit.wikimedia.org/r/511754. The failing test doesn't exist any more.

thiemowmde closed this task as Resolved.May 29 2019, 6:31 PM
thiemowmde claimed this task.