Page MenuHomePhabricator

qrpedia.org and qrwp.org are down
Open, HighPublic

Description

It looks like http://qrpedia.org and http://qrwp.org are offline.

This means that all QRpedia QR codes in the wild are broken.

Event Timeline

Samwilson created this task.Nov 8 2018, 6:58 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 8 2018, 6:58 AM
Samwilson updated the task description. (Show Details)Nov 8 2018, 6:58 AM
Restricted Application added a project: Traffic. · View Herald TranscriptNov 8 2018, 7:03 AM
Samwilson triaged this task as High priority.Nov 10 2018, 10:04 AM
Samwilson added a subscriber: Gnangarra.
Restricted Application added a project: Operations. · View Herald TranscriptNov 10 2018, 10:04 AM
BBlack added a subscriber: BBlack.

Removing the ops/traffic/domains tags, as the Foundation doesn't operate anything about these domains (we don't own or operate the DNS, the IPs, or the servers). Whois says they belong to:

Registrant Organization: Cultural Outreach Limited
Registrant State/Province: London
Registrant Country: GB

For qrpedia.org, the DNS and hosting appears to be with Amazon Web Services, and for qrwp.org, it's LiveDNS.co.uk for the DNS and Rackspace for the hosting.

BBlack removed a subscriber: BBlack.Nov 10 2018, 1:02 PM
Dzahn added a subscriber: Dzahn.Nov 10 2018, 4:24 PM

https://qrpedia.org/ looks up (now, to me)

https://qrpedia.org/ looks up (now, to me)

https://qrwp.org is still offline.

Gnangarra added a comment.EditedNov 10 2018, 10:21 PM

asking is it possible to for the qrpedia to be replaced or redirtected to https://meta.wikimedia.org/wiki/Free_Knowledge_Portal which is on the toolserver and uses the stable qnumbers from wikidata

Aklapper added a comment.EditedNov 10 2018, 11:18 PM

@Gnangarra: I guess you need to ask the QRPedia folks about that...
This task is about two domains being down, which is unrelated to discussing Free Knowledge Portal. :)
(Edit: What I want to express is probably: Could you file a separate task for that discussion? Thanks!)

Samwilson updated the task description. (Show Details)Nov 10 2018, 11:57 PM

@BBlack I sort of thought that might be the case; thanks for confirming. Sorry for the noise.

@MichaelMaggs are you someone who might know how to progress this?

Hi; not sure how to flag this but QRPedia issues are probably best assigned to me for now.

I've been made aware of the issue & its something I can get fixed. ETA will probably be later tonight or tomorrow.

ErrantX claimed this task.Nov 13 2018, 10:35 AM

Specific problems I am seeing are:

  • qrwp.org is unavailable (problem known; will fix & RCA)
  • http redirection seems to have stopped working (https is fine). Will investigate.

not sure how to flag this but QRPedia issues are probably best assigned to me for now.

@ErrantX: Please see https://www.mediawiki.org/wiki/Phabricator/Help#Receiving_updates_and_notifications - thanks!

Pyb added a subscriber: Pyb.Nov 19 2018, 12:40 PM

Hi @ErrantX, is there some news about the bug? One of our partner just launched qrpedia in September ;)

Gnangarra added a comment.EditedNov 20 2018, 8:18 AM

Hi Guys

Have just heard from Toodyay all the codes created before this went are no longer working, new codes being created now are fine, unfortunately our partner has invested in replacements for all of the original plates and now nothing works
https://commons.wikimedia.org/wiki/File:Toodyaypedia_plates_stg_1_gnangarra_fs-1.jpg for an original code created in 2014, and we have another set created in 2016 that also dont work... Its not a good look

In addition to the codes in Toodyay we also have codes in Fremantle, as well some in Sydney and on all of WMAU business cards so a fix would be preferred to the costly exercise of replacing everything

@Aklapper Thanks, that's useful!

Apologies for the delay in replying; I had believed this to be fixed. Unfortunately @Gnangarra reply suggests otherwise! I'll look into it ASAP.

If possible could you share as many qrwp.org links as possible? The codebase isn't mine and it's a bit old and needs some TLC in places. So as much info as you have is helpful.

To put the scope of the problem in context - the redirect code just didn't work well at all & so I'm using an Nginx config to manage the redirect, which I suspect has unexpected behaviours. Sharing as much data as possible will help me fix it.

BTW I spotted a certificate issue this morning - please try again and see if that has helped.

@ErrantX
I have just uploaded the original QRcodes to Commons, here is a the category of codes created for toodyay in 2014 https://commons.wikimedia.org/wiki/Category:QRpedia_codes_for_Toodyay

I have also uploaded all the Fremantle codes as well https://commons.wikimedia.org/wiki/Category:QRpedia_codes_for_Freopedia will upload the second set of toodyay codes if needed

@ErrantX it looks like qrwp.org is still not working (both HTTPS and not, and with and without www.). But en.qrwp.org is working for both HTTPS and not (yay! that means lots, but perhaps not all, of the codes are working I think?).

Is the source code available publicly anywhere? Would it help to have another pair of eyes on it? Or are these problems all server-config related?

Thanks for working on it!

Thanks for helping to sort this out. WMAU very much appreciates everyones efforts

It looks like there's some issues with double-encoding in some codes. For example, the centre plaque in
https://commons.wikimedia.org/wiki/File:Toodyaypedia_plates_stg_1_gnangarra_fs-1.jpg
resolves to
http://en.qrwp.org/St_John_the_Baptist_Church,_Toodyay_%25281963-_%2529
instead of
http://en.qrwp.org/St_John_the_Baptist_Church,_Toodyay_%281963-_%29
(i.e. the % was URL-encoded a second time).

Did a prior version of the QRpedia software handle this double-encoding, or was this code always incorrect?

@Samwilson double encoding has been an ongoing issue - I have a suspicion I've fixed it in the past but now the redirection is server-based only and so it's probably failing. Will explore a fix.

Can you open a new issue and assign it to me?

no there is two churches with that name, someone moved one and we had to
create a redirect

@Pyb right so French Wikipedia redirects don't work; that's an issue, will resolve.

@Pyb right so French Wikipedia redirects don't work; that's an issue, will resolve.

@Samwilson double encoding has been an ongoing issue - I have a suspicion I've fixed it in the past but now the redirection is server-based only and so it's probably failing. Will explore a fix.
Can you open a new issue and assign it to me?

Done: T210050.

ErrantX closed this task as Resolved.Nov 21 2018, 9:38 PM

I'm marking this ticket resolved; I believe I have fixed the redirection and domain issues. Please re-open if additional issues persist.

Samwilson reopened this task as Open.Nov 21 2018, 11:42 PM

The non-HTTPS for http://qrpedia.org seems to still not be working. https://downforeveryoneorjustme.com/qrpedia.org

Pyb added a comment.Nov 22 2018, 8:53 AM

and fr.qrwp.org add a second slash (/).
Eg. https://fr.qrwp.org/Wikipedia is redirecting to https://fr.wikipedia.org/wiki//Wikipedia

Geertivp added a subscriber: Geertivp.

I have created a related ticket T214268 for the double // problem since it impacts ALL languages, except EN.

Base added a subscriber: Base.Mar 4 2019, 8:40 PM

I have created a related ticket T214268 for the double // problem since it impacts ALL languages, except EN.

As of today - half a year on - this is reportedly still not resolved:

https://twitter.com/MonsieurBraun/status/1135987209486647296

Pyb added a comment.Jun 5 2019, 7:43 AM

if it may help, WMFr have put a server in place for the project "QRpedia in Sevran". For eg https://qrwm.org/Q42

we are still having issues with apostrophes within a page title not working. https://meta.wikimedia.org/wiki/Free_Knowledge_Portal addresses the issue and provides its linking via Wikidata, WMAu has some resources in its new sAPG to help transition qrpedia to Wikidata as the hub where special characters in URL are no longer needed.

Quarz added a subscriber: Quarz.Jun 5 2019, 8:48 AM

The issues still persist:
a) Double slashes in de.Wikipedia: https://de.qrwp.org/Berlin
The solution should be known at WMUK, because the bug has been fixed for other language versions.

b) Incorrect URL resolution for articles with non-letter character:
The issue already existed once in 2014, but was quickly fixed by a simple method at qrwp.org: With the incoming URL, do a regex_replace or string_replace, find '%25' replace with '%'.
https://en.wikipedia.org/w/index.php?title=User_talk:Victuallers&oldid=592634542#QRpedia_bug_-_Apostrophes._HELP!
I would like to know why the fix was undone.

This task is called "qrpedia.org and qrwp.org are down/offline".
This task is still open because http://qrpedia.org cannot be reached.

Anything else, like double slashes, is offtopic here because it is not about a complete websites being offline.
Please report separate tasks for separate problems. See https://www.mediawiki.org/wiki/How_to_report_a_bug .
Thanks.

Thats still open too https://phabricator.wikimedia.org/T210050 the issue is these arent getting addressed no matter how many tickets get opened... One ticket is easier to follow than 50 when the issues appear to be stemming from the same issue

@Gnangarra: No, this is not how it works. Please do not intentionally add unrelated comments to task if you would like to continue being active in Wikimedia Phabricator. One task per one issue, as explained before. Resources are unlimited. Please read "Why has nobody fixed this issue yet?" on https://www.mediawiki.org/wiki/Bug_management/Development_prioritization . Thanks.

Resources are unlimited

Mine, and I suspect @Gnangarra's and other volunteers', are not.

Please read "Why has nobody fixed this issue yet?"

I've read that. I cannot see the bit about high profile and public-facing - not to mention external-partnership - projects which remain inoperable after many months.

Sorry, that was a typo. I meant "resources are limited", obviously.

Resources are unlimited

Mine, and I suspect @Gnangarra's and other volunteers', are not.

Please read "Why has nobody fixed this issue yet?"

I've read that. I cannot see the bit about high profile and public-facing - not to mention external-partnership - projects which remain inoperable after many months.

Basically yeah, the problems have been around for over two years, if stopping me from being active on phabricator is going to fix the problems with the QR codes I have no problem with that option

@Gnangarra: I think there is a misunderstanding here. I merely asked you to stay on-topic on tasks. See "Thoughts unrelated to the topic of the report". Whether you stick to community expectations on Phabricator won't magically influence if code issues get fixed by someone or not, though.

@Aklapper there may be a misundertsanding here, my understanding is QRpedia isnt working, it hasnt been working for over two years, I dont have the knowledge to decide on the nuances of whether its related to the same or different lines of code all I know is its not functioning. the message we get is bad url/url doesnt exist. and we've been getting that for a couple of years.

@Gnangarra: Correct. This task is about the websites being unreachable. That's a different issue than the websites being reachable, but after using the reachable website you end up in wrong places like https://fr.wikipedia.org/wiki//Wikipedia (double slash in URL), hence off-topic in this task.

Dzahn added a comment.Jun 28 2019, 1:02 AM

This task is called "qrpedia.org and qrwp.org are down/offline".
This task is still open because http://qrpedia.org cannot be reached.

status as of today:

  • qrpedia.org can be reached and i see a form to create QR codes
  • qrwp.org can be reached but just redirects me to the en.wikipedia main page

So technically both are "up" now and this ticket can be closed. Assuming that this is the desired state, with qrpedia.org being the tool to create codes and qrwp.org being the one that does the redirects to articles when codes are being used.

qrwp.org without any subdomain or path is meant to redirect to enwp main page, so that's good. It seems that URLs like https://fr.qrwp.org/Trait%C3%A9_de_Paris_(1815) are redirecting correctly (although with the extra-slash problem described in T214268).

However, I'm not sure if everything is fine, because this still says it's down: https://downforeveryoneorjustme.com/qrwp.org and from my machine here I get intermittent results, e.g.:

$ curl -I http://qrwp.org
curl: (6) Could not resolve host: qrwp.org
Dzahn added a comment.EditedJun 28 2019, 2:08 PM

@ErrantX For some reason i was able to open qrwp.org and got to the en.wikipedia front page earlier but also i can confirm now it's like there is no DNS entry for it. It says AWS name servers are responsible. could you take a look at DNS settings there? Currently there seems to be no A or CNAME record for qrwp.org .

edit: while there are DNS records for fr.qwp.org and en.qwp.org.. so this is just about the blank domain name

This issue still exists, but as it's not failing on en.qrwp.org it's not a concern for WMAU projects anymore; removing that project.