Page MenuHomePhabricator

Welcome survey: "More topics" menu closes after every selection
Closed, InvalidPublic

Description

  1. With a newly created user that belongs to "_group":"exp1_group1, log in to enwiki in betalabs.
  2. The Welcome survey form will be presented - start filling it out and click to add a topic from the drop down selection list. The topic will be added.
  3. 'Add more' will be displayed' beside the topic, but the dorp down list won't open anymore:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 10 2018, 12:24 AM
SBisson added a subscriber: RHo.Nov 10 2018, 2:23 PM

That's how TagMultiselectWidget works unfortunately. If you click outside and inside the box the menu re-appears. Or if you start typing, search results from the menu will be shown.

It's not clear to me if the current behaviour is wrong or how it could be improved. CC @RHo

Aklapper renamed this task from Welcome survey: cannnot add more than one topic to Welcome survey: cannot add more than one topic (due to TagMultiselectWidget behavior) .Nov 10 2018, 7:21 PM
RHo added a comment.Nov 12 2018, 1:48 PM

hi @SBisson - I referred to way that the block email field works in Preferences as the expected behavior, whereby the user should be able to select multiple items in the droplist, as well as add their own. Is there some parameter for TagMultiselectWidget that needs to be set for this to work as expected? Or perhaps should the MenuTagMultiselect be used instead?

Here's an animated gif of the expected behavior (must be opened full screen to view animation):

hi @SBisson - I referred to way that the block email field works in Preferences as the expected behavior, whereby the user should be able to select multiple items in the droplist, as well as add their own. Is there some parameter for TagMultiselectWidget that needs to be set for this to work as expected? Or perhaps should the MenuTagMultiselect be used instead?

Here's an animated gif of the expected behavior (must be opened full screen to view animation):

That's exactly how it works.

SBisson renamed this task from Welcome survey: cannot add more than one topic (due to TagMultiselectWidget behavior) to Welcome survey: "More topics" menu closes after every selection.Nov 12 2018, 5:44 PM
RHo added a comment.Nov 12 2018, 5:57 PM

Oh I was under the impression from the task description that the error is that "the drop down list won't open anymore" after one selection is made? Can @Etonkovidova confirm?

Etonkovidova closed this task as Invalid.Nov 13 2018, 9:54 PM

@SBisson is right:

That's how TagMultiselectWidget works unfortunately. If you click outside and inside the box the menu re-appears.

@RHo - yes, it seems to be working as intended. Ideally, the drop down should appear automatically; it's not too intuitive to click outside and click again to make the drop-down work. I am closing the task.