Page MenuHomePhabricator

Expand the set of bundled extensions and skins in MediaWiki 1.34
Open, Needs TriagePublic

Description

Current proposal:

Bundled extensions should satisfy the following conditions:

  • Passed security review or already Wikimedia deployed
  • Voting CI structure tests
  • Runs MediaWiki-CodeSniffer
  • Runs phan
  • Runs seccheck
  • Supports MySQL, SQLite, and Postgres (if there are schema changes)
  • GPL v2 or later compatible license
  • Extension's default configuration provides optimal experience
  • Tested with web installer

Related Objects

StatusAssignedTask
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
ResolvedCCicalese_WMF
OpenNone
OpenNone
ResolvedDaimona
OpenNone
Resolvedmatej_suchanek
ResolvedDaimona
OpenDaimona
Resolvedmatej_suchanek
Resolvedmatej_suchanek
OpenDaimona
OpenNone
OpenNone
OpenNone
OpenNone
InvalidNone
OpenNone
OpenNone
Resolveddemon
ResolvedLegoktm
StalledNone
OpenNone
OpenNone
OpenNone
OpenNone

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 10 2018, 6:58 PM
Jdforrester-WMF renamed this task from Expand the set of bundled extensions and skins in MediaWiki 1.33 to Expand the set of bundled extensions and skins in MediaWiki 1.34.Jun 7 2019, 9:00 PM
Jdforrester-WMF edited projects, added MW-1.34-release; removed MW-1.33-release.
CCicalese_WMF updated the task description. (Show Details)